Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Pydio using NGINX, PHP-FPM, and MySQL

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,949
ohh haha i thougt i nbeed to open it. but i didnt know not with show haha

so no i have opened like you said and ehmm.. check that out XD : http://pastebin.com/k0vnP7qi

seems i am doing somthing wrong. have some errors

so maybe i do a full fresh install of the freenas on my virtualbox so i can do it from begining new?
I don't know what you're trying to show me, that the config file already has stuff in it? in this case you replace it everything. there's probably a way to delete a line at a time, I don't know with that editor though.

your going to reinstall the OS from scratch?! why? that's wouldn't change anything, the config file would always exists. also, that's what jails are for. if you really needed to start over just create a new jail and try again.

finally you're running freenas on virtual box? I don't even know if that's supported. I always run it on bare metal.
 

WhiteEagle112

Neophyte
Joined
Dec 24, 2014
Messages
8
I don't know what you're trying to show me, that the config file already has stuff in it? in this case you replace it everything. there's probably a way to delete a line at a time, I don't know with that editor though.

your going to reinstall the OS from scratch?! why? that's wouldn't change anything, the config file would always exists. also, that's what jails are for. if you really needed to start over just create a new jail and try again.

finally you're running freenas on virtual box? I don't even know if that's supported. I always run it on bare metal.
i run freenas just for trying, for testing like now, for knowlege. i will build then one for me and run it on real hardware. but just for testing i wanna use it this way.
http://olddoc.freenas.org/index.php/FreeNAS®_in_a_Virtual_Environment

okey i thought maybe i did somthing wrong becouse of that error mesages. so i can clean all that stuff on that config fille and copie your stuff in it and chance that what you write?
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,949
i run freenas just for trying, for testing like now, for knowlege. i will build then one for me and run it on real hardware. but just for testing i wanna use it this way.
http://olddoc.freenas.org/index.php/FreeNAS®_in_a_Virtual_Environment

okey i thought maybe i did somthing wrong becouse of that error mesages. so i can clean all that stuff on that config fille and copie your stuff in it and chance that what you write?
Ahh, I see, ok.

I didn't see an error message. Just what was in the config file. If you want to complete this tutorial you are going have to be able to create and edit config files.
 

WhiteEagle112

Neophyte
Joined
Dec 24, 2014
Messages
8
Ahh, I see, ok.

I didn't see an error message. Just what was in the config file. If you want to complete this tutorial you are going have to be able to create and edit config files.
okey then i will learn in sometimes.. i did it now this way that i did a "Network Share" so i can go to the file and edit it with my notepad++ this is maybe also a way... and for me a easy way atm sorry XD but yeah i wanna take a look for editing configs in shell. do you have a god adress where i can learn ? :smile:
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,949
okey then i will learn in sometimes.. i did it now this way that i did a "Network Share" so i can go to the file and edit it with my notepad++ this is maybe also a way... and for me a easy way atm sorry XD but yeah i wanna take a look for editing configs in shell. do you have a god adress where i can learn ? :)
you might be able to do it that way, but seems really inefficient and stuff might be made with weird permissions. Not sure online resources, but others might know. I haven't used anything but linux/freebsd for a few years so i prefer the commandline, especially for these small config edits.

Just checking, you are using putty to connect to your jail, not the web terminal? that may make things easier to use as well.
 

WhiteEagle112

Neophyte
Joined
Dec 24, 2014
Messages
8
you might be able to do it that way, but seems really inefficient and stuff might be made with weird permissions. Not sure online resources, but others might know. I haven't used anything but linux/freebsd for a few years so i prefer the commandline, especially for these small config edits.

Just checking, you are using putty to connect to your jail, not the web terminal? that may make things easier to use as well.

yeah i know its not the right way but only for testing if i become it runnig, for me its okey for now :) becouse like i said, i dont know much about that things.

ehm no the web terminal, so should i download PuTTY?
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,949
yeah i know its not the right way but only for testing if i become it runnig, for me its okey for now :) becouse like i said, i dont know much about that things.

ehm no the web terminal, so should i download PuTTY?
i suggest you use Putty if you're going to be doing this tutorial from Windows. you'll also need to enable SSH, and for ease enable root login with password over SSH.
 

Scareh

Member
Joined
Jul 31, 2012
Messages
182
a quick question:

every time i reboot the server pydio doesn't work anymore, when i check its nginx giving me problems:

root@pydio:/ # service nginx start
Performing sanity check on nginx configuration:
Shared object "libpcre.so.1" not found, required by "nginx"
Starting nginx.
Shared object "libpcre.so.1" not found, required by "nginx"
/usr/local/etc/rc.d/nginx: WARNING: failed to start nginx

any idea how to avoid this/solve? Last time i just reinstalled nginx, but kinda want to avoid doing that every time
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,949
a quick question:

every time i reboot the server pydio doesn't work anymore, when i check its nginx giving me problems:

root@pydio:/ # service nginx start
Performing sanity check on nginx configuration:
Shared object "libpcre.so.1" not found, required by "nginx"
Starting nginx.
Shared object "libpcre.so.1" not found, required by "nginx"
/usr/local/etc/rc.d/nginx: WARNING: failed to start nginx

any idea how to avoid this/solve? Last time i just reinstalled nginx, but kinda want to avoid doing that every time
I don't know how it would ever start with that error. try 'pkg upgrade' to catch that lib up to date.
 

Scareh

Member
Joined
Jul 31, 2012
Messages
182
the pkg upgrade didn't do a thing.

I just did a remove/install on pcre, which requires me to reinstall all php and all nginx pkg's. After that i upload via ftp all the files i changed (nginx and php conf files) after which it works.
It just sucks i have to do that every time i either reboot the jail or the server. And with the current update rates thats every few days.
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,949
the pkg upgrade didn't do a thing.

I just did a remove/install on pcre, which requires me to reinstall all php and all nginx pkg's. After that i upload via ftp all the files i changed (nginx and php conf files) after which it works.
It just sucks i have to do that every time i either reboot the jail or the server. And with the current update rates thats every few days.
something sounds really weird here. why would rebooting change the files you have on disk?! after you get things working please snapshot the jail, then try restarting the jail and see if you get the error again.

and you don't have to uninstall everything, do 'pkg delete -f pcre' then reinstall pcre.
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,949
and why do you have to keep reuoloading your configs? installing/uninstalling packages won't touch edited configs.
 

Scareh

Member
Joined
Jul 31, 2012
Messages
182
sry for the late responds but:

the pkg delete pcre and install worked wonders.
I upgraded my controller and freenas and had to reboot, and again the pydio jail/nginx stuff stopped working.
Any other suggestions?
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,949
sry for the late responds but:

the pkg delete pcre and install worked wonders.
I upgraded my controller and freenas and had to reboot, and again the pydio jail/nginx stuff stopped working.
Any other suggestions?
same error? I'm pretty confused at how your system changes what's on disk from a reboot. never seen something like that before. do you have any scripts/tasks that revert snapshots of your jail?
 

Scareh

Member
Joined
Jul 31, 2012
Messages
182
nope i only set up the snapshot because you asked me to, and yes the same error:

root@pydio:/ # service nginx start
Performing sanity check on nginx configuration:
Shared object "libpcre.so.1" not found, required by "nginx"
Starting nginx.
Shared object "libpcre.so.1" not found, required by "nginx"
/usr/local/etc/rc.d/nginx: WARNING: failed to start nginx

i'm asuming noone else has this error? I hope its not related at the fact that i'm putting pydio in my www folder instead of a subfolder, and that i'm putting it on a specific port (8080) instead of a normal one.
Seems illogical to me if it were to be that tbh.

edit:
had the same problem when i was using ports instead of pkg's (link : https://forums.freenas.org/index.php?threads/nginx-jail-shared-object-not-found.18783/#post-103582)

would this have the same result (aka fix it?)
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,949
nope i only set up the snapshot because you asked me to, and yes the same error:

root@pydio:/ # service nginx start
Performing sanity check on nginx configuration:
Shared object "libpcre.so.1" not found, required by "nginx"
Starting nginx.
Shared object "libpcre.so.1" not found, required by "nginx"
/usr/local/etc/rc.d/nginx: WARNING: failed to start nginx

i'm asuming noone else has this error? I hope its not related at the fact that i'm putting pydio in my www folder instead of a subfolder, and that i'm putting it on a specific port (8080) instead of a normal one.
Seems illogical to me if it were to be that tbh.
agreed those changes are unrelated. there is something really weird going on here where files are actually being changed during a reboot. maybe you can try setting up a second jail for pydio and see if you have the same issue.
 

Scareh

Member
Joined
Jul 31, 2012
Messages
182
sry was editting my post while you posted something, hope you still see it.
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,949
that looks eerily similar to your problem. I'd definitely try it out.
 

Scareh

Member
Joined
Jul 31, 2012
Messages
182
doesn't fix the situation :(
can perfectly uninstall/install it, but on restarting the jail, nginx is down again with the same error.
 
Status
Not open for further replies.
Top