Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Pydio using NGINX, PHP-FPM, and MySQL

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.

Lessbones

Junior Member
Joined
Oct 17, 2016
Messages
22
@Lessbones
Ohh, I hit the same issue at first. During setup there was a part where it asked where pydio was available and I think I put http://jail_IP/pydio

I should add that to the steps, I have a feeling that setting would be stored in one of pydio's config files if you don't want to start from scratch.
ok this seems to have worked! Now i'll see if i can finally get actionfs ZIP working, and if this helps overcome the filesize limit I couldn't solve on my other installation--

thanks again.

Also there's still an issue with the guide in the step for fetching from the source:

i'm not sure why it says

Code:
mv ./pydio-core-* /usr/local/www/pydio

with the "." first, but unless you "rm pydio-core-*.tar.gz" first, this command doesn't work as is (without the . in front of it)

thanks again!
 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,949
ok this seems to have worked! Now i'll see if i can finally get actionfs ZIP working, and if this helps overcome the filesize limit I couldn't solve on my other installation--

thanks again.

Also there's still an issue with the guide in the step for fetching from the source:

i'm not sure why it says

Code:
mv ./pydio-core-* /usr/local/www/pydio

with the "." first, but unless you "rm pydio-core-*.tar.gz" first, this command doesn't work as is (without the . in front of it)

thanks again!
good catch, ok I'll double check what I posted works. Thanks!
 

Intel

Junior Member
Joined
Sep 30, 2014
Messages
18
I am following the instructions, but got an error apparently one of the packages probably changed names? here is the error

Code:
root@pydio:/usr/ports/www/nginx # pkg upgrade && pkg install nginx mariadb101-server php70-extensions php70-exif php70-gd php70-mcrypt php70-mysqli php70-openssl php70-zlib php70-APCu
Updating FreeBSD repository catalogue...

FreeBSD repository is up to date.

All repositories are up to date.

pkg: No packages available to install matching 'php70-APCu' have been found in the repositories

 

Joshua Parker Ruehlig

Wizened Sage
Joined
Dec 5, 2011
Messages
5,949
I am following the instructions, but got an error apparently one of the packages probably changed names? here is the error

Code:
root@pydio:/usr/ports/www/nginx # pkg upgrade && pkg install nginx mariadb101-server php70-extensions php70-exif php70-gd php70-mcrypt php70-mysqli php70-openssl php70-zlib php70-APCu
Updating FreeBSD repository catalogue...

FreeBSD repository is up to date.

All repositories are up to date.

pkg: No packages available to install matching 'php70-APCu' have been found in the repositories

yeah, it was renamed to pecl-APCu, which is possibly not provided as a package since it is compiled with the non-default php-70
you can compile it from ports if you want to enable APC cache
 
Status
Not open for further replies.
Top