Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

FreeNAS not showing up in network tab on Windows

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Joined
Sep 8, 2018
Messages
1
My freenas is configured as best I can. I have a windows share setup but my windows pc can't find it in the network tab. It can see other PCon the network but not the nas. If I try to ping the servers IP with command prompt I can and it works but it still won't show up in the network and I can't map the drive. I have been troubleshooting for almost 4 hours and I would love some help. Thanks upload_2018-9-8_14-50-54.png
 

BigDave

FreeNAS Enthusiast
Joined
Oct 6, 2013
Messages
2,479
It's more efficient to browse a share with this method.
[WinKey]+[R]
then add your FreeNAS IP in the window that appears.
EXAMPLE:\\192.168.1.101
then login with USERNAME/PASSWORD if you use them.
Once the window opens, highlight your shared folder
and look for the Easy access and choose Map as drive
in the drop down.
mapDRIVE.JPG
 

schwarci

Newbie
Joined
Nov 9, 2014
Messages
3
I found this solution for win 10 x64! Worked for me!

https://social.technet.microsoft.co...ble-or-quoterror-code?forum=w8itpronetworking

The following worked for me.​
In Control panel, change view to small icons so you can see all options.​
Select Credential Manager​
Click on Windows Credentials button at top of the list​
You will now see 3 categories of credentials.​
On top: Windows Credentials.​
In the middle: Certificate Based Credentials​
On bottom: Generic Credentials​
I found my NAS in "Generic Credentials" but my NAS is configured for windows based authentication.​
So, I deleted the entry in Generic Credentials and created a new entry in Windows Credentials with my server name (no \\ just the server name) and an ID and Password that I had configured on the NAS.​
I presume this causes Windows 8 to send the credentials to the NAS in the same manner it would send to another Windows machine... which my NAS understands as it is configured to emulate windows shared folders. My mapped drive immediately started working and I'm able to browse via UNC naming in Explorer to shared folders on the NAS.​
Prior to discovering this fix, the following workaround was my only option. not ideal, but could be useful for testing purposes.​
Start, type cmd and run as an administrator.​
Type the following: net use \\<nameofyourserver> * /user:administrator​
You will be prompted for the NAS administrator password. after you enter it should say Command executed successfully​
Now, type Explore \\<nameofyourserver> and it will launch an explorer window pointing to the root shares of your NAS.​
This does appear to be materially different default behavior than in prior versions of windows. Previously if you just attempted to navigate to a NAS by typing the UNC into the Address window of Windows Explorer, you would get a credentials prompt... save the credentials and it always worked. Don't save the credentials and it would still work but would prompt you again after logout/reboot/timeout.​
In windows 8 it appears to attempt to authenticate via Generic credentials before attempting via Windows credentials. My NAS apparently responds that is ok... or windows 8 assumes that it is ok... and then I get Win8 permanently attempting to use generic with that network name.​
You can override via net use command... which will force a condition using windows credentials for the Explorer you launch from that command window... or you can fix it in credentials manager by deleting the Generic entry and creating an entry in Windows section.​
Now... this doesn't solve the problem if, for security reasons, you prefer to be prompted for credentials when connecting to the NAS. For that reason I consider this a defect, especially because of the difference compared to how it works in Windows 7 and previous versions including Windows Server products.​
Good luck.​
Cheers​
Jeff​
 
Last edited:

Yorick

Dedicated Sage
Joined
Nov 4, 2018
Messages
1,783
That helps with credentials. For me as well, FreeNAS doesn't show up as a "Computer" in Win10, while other Win10 computers do. The usual suspects in Win10 Advanced Sharing are set .. Private network, "Turn on sharing so anyone with network access can read and write files in the public folders", "turn on network discovery -> automatic setup of network connected devices".

That's good enough so Win10 can see each other, but FreeNAS doesn't show up in Explorer. I can type \\freenas and it'll be right there.

It's a minor annoyance. I still wonder what Samba does that makes browsing in a workgroup not, actually, work.
Edit: This is a good-enough workaround. https://www.techrepublic.com/article/how-to-connect-to-linux-samba-shares-from-windows-10/
 
Last edited:

coopdavillage

Newbie
Joined
Jun 1, 2019
Messages
1
That helps with credentials. For me as well, FreeNAS doesn't show up as a "Computer" in Win10, while other Win10 computers do. The usual suspects in Win10 Advanced Sharing are set .. Private network, "Turn on sharing so anyone with network access can read and write files in the public folders", "turn on network discovery -> automatic setup of network connected devices".

That's good enough so Win10 can see each other, but FreeNAS doesn't show up in Explorer. I can type \\freenas and it'll be right there.

It's a minor annoyance. I still wonder what Samba does that makes browsing in a workgroup not, actually, work.
Edit: This is a good-enough workaround. https://www.techrepublic.com/article/how-to-connect-to-linux-samba-shares-from-windows-10/

This did not work for me. I have gone over the manual several times and searched all over but I can still not see my server.
Not sure if its just something I did wrong or not but any help would be great.

I have the pool created, dataset created, and share created. I am the only one that will ever be accessing this so based on the manuals instructions I set it to be a guest access so that I dont need to login to access it.

With all of this I still can not see anything for the freenas. following your quote above still does not work...

Any suggestions on what i might be done wrong?
 
Top