Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Setting up FreeNAS 9.2.0 with Transmission and Couchpotato as a DLNA-Server

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.

FlyingPersian

Member
Joined
Jan 27, 2014
Messages
210
Hi
You made a mistake in your text explanation, but the picture to it is correct.

Next, go to the “Post Processing” settings. In the “TV Download Dir”, enter your Series-Destination “/media/series” and check the “Scan and Process”-box. You can also edit additional settings on this page but they are not important right now. In the end your settings should probably look like this:
It has to be "/media/downloads" because it is the dir where you download all your shows to. I did this wrong and got some errors like "This show isn't in your list, you need to add it to SB before post-processing an episode".
 

zufallsheld

Member
Joined
Dec 27, 2013
Messages
54
Follow up...I assume we have multiple storages per jail correct? i.e. one storage for download another for movies (couch potato)
that's right.

Hi
You made a mistake in your text explanation, but the picture to it is correct.



It has to be "/media/downloads" because it is the dir where you download all your shows to. I did this wrong and got some errors like "This show isn't in your list, you need to add it to SB before post-processing an episode".
Thanks, I corrected it.
 

Mike Haskell

Junior Member
Joined
Jan 17, 2014
Messages
14
both couch potato and sickbeard have updates. can they be updated from the servers or should this be done from the plugin menu
 

Titus A Duxaa

Newbie
Joined
Feb 16, 2014
Messages
2
Hi,
Firstly thanks for the excellent tutorial, so far I have most things working.

My biggest problem is with pointing the browser at the various plugins.

Simply entering 192.168.2.2 or .3 or .4 results in the old Oops from chrome and firefox.
Entering 192.168.2.2:9091 lets me see transmission but I don't have anything for couchpotato.
Plex comes back with - plex has a problem connecting your server.

Any tips.
Thanks
TAD
 

zufallsheld

Member
Joined
Dec 27, 2013
Messages
54
both couch potato and sickbeard have updates. can they be updated from the servers or should this be done from the plugin menu
They can be updated from the servers, that's at least, what I am doing.


Hi,
Firstly thanks for the excellent tutorial, so far I have most things working.

My biggest problem is with pointing the browser at the various plugins.

Simply entering 192.168.2.2 or .3 or .4 results in the old Oops from chrome and firefox.
Entering 192.168.2.2:9091 lets me see transmission but I don't have anything for couchpotato.
Plex comes back with - plex has a problem connecting your server.

Any tips.
Thanks
TAD
You have to open the right ports. Couchpotato is (on default) 5050, sickbeard 8081. Assuming, couchpotato runs on 192.168.2.2, you have to open 192.168.2.2:5050 in the browser.
 

Bmck26

Member
Joined
Dec 9, 2013
Messages
44
Has anyone had any trouble changing the settings.json file? I can't seem to get it to work. I follow the instruction in the guide but it says "Command not found" when I try to edit the file vis SSH. I know the file is there. I can go into the folders through windows file explore. The path in the guide is correct. But if I edit the .json file in note pad then Transmission won't start.
 

Supa

Member
Joined
Jan 10, 2014
Messages
204
What should the source and destination addresses be for the jails when adding storage?

Mine's looking like this right now... If anyone completed this and has skype / hangouts help would be awesome.... (s/n: exzacklyright) I'm in irc too.


Might be good to paste your jails setup OP.


 

Supa

Member
Joined
Jan 10, 2014
Messages
204
Think I finally have it setup. my only question is how does sickbeard / Couchpotato distinguish between a TV Series and Movie if they're both being put into /media/downloads?
 

zufallsheld

Member
Joined
Dec 27, 2013
Messages
54
Has anyone had any trouble changing the settings.json file? I can't seem to get it to work. I follow the instruction in the guide but it says "Command not found" when I try to edit the file vis SSH. I know the file is there. I can go into the folders through windows file explore. The path in the guide is correct. But if I edit the .json file in note pad then Transmission won't start.
please show me the command you are using.


Think I finally have it setup. my only question is how does sickbeard / Couchpotato distinguish between a TV Series and Movie if they're both being put into /media/downloads?
that's a problem I am still trying to figure out.
 

Supa

Member
Joined
Jan 10, 2014
Messages
204
please show me the command you are using.



that's a problem I am still trying to figure out.
The only other problem is with the CP renamer. Everything get's renamed fine but the folders get left over in /mnt/vol1/downloads and I can't delete them. Windows does nothing. I can delete their contents, rename the folder, etc but not delete it.

The only way I've been able to delete them is run:

rm -rf /mnt/vol1/downloads
Might be some CIFS issue... or Transmission issue. I have no idea :D
 

marcevan

Senior Member
Joined
Dec 15, 2013
Messages
408
Think I finally have it setup. my only question is how does sickbeard / Couchpotato distinguish between a TV Series and Movie if they're both being put into /media/downloads?

Excellent question.

I would have loved to see transmission get a download directory from the source like Sick or Couch so we can have a downloads/movies and download/tv directories that couch and sick can poach from.

However, it does seem like Sick matches to existing TV shows so it won't grab a movie unless it's names improperly (e.g., tv show it has is Revolution and you download a movie called revolution). Hmmm.

But let it be and see what happens.
 

cyberjock

Inactive Account
Joined
Mar 25, 2012
Messages
19,526
For the answer to that question, you should ask the Sick/Couch forums/IRC. We just provide the app. We aren't involved with its development.
 

marcevan

Senior Member
Joined
Dec 15, 2013
Messages
408
I'm not barking up the "please do this" tree. I'm trying to help the poster and sympathize. But he should just let things be and trust that if sick and couch operate with trans simultaneously it will work.

If not, he should post the circumstances and any logs.
 

diedrichg

Neophyte Sage
Joined
Dec 4, 2012
Messages
1,302
Amazing! subscribed
 

andyclimb

Member
Joined
Aug 17, 2012
Messages
101
Thanks for the great tutorial, I followed it and it worked. My server then refused to boot no idea why why but it is likely to have been some of the other stuff I've been trying. I then thought that it would be way easier if you could install all the plugins into one jail. Then u just have to share the one media folder and things get a lot easier. This is very possible...

Create a plugin jail, and add the raw_sockets=true, setting. Copy it from the transmission jail config. Then visit the jails help page on freenas , or click here

http://www.freenas.org/downloads/plugins/9/

Download all the pbis u want and then upload them by clicking the brown pbi button when viewing the jails. U essentially end up with the same thing, but they are all on the same jail! So only one media directory to mount.






Sent from my iPad using Tapatalk
 

joshmxpx

Junior Member
Joined
Apr 12, 2014
Messages
14
Ok I followed the guide provided, thanks for that.

So far everything is mostly working and no hiccups. Sickbeard seems to be running incident free, but I am having a problem between transmission and couch potato. I can add a movie fine in couch potato, it pops up in transmission, finishes downloading, but then disappears into the ether...

The torrent automatically gets removed from transmission, and I can't find the finished download anywhere... Couch potato can't find the files, and nothing happens.

Can someone please give me some advice on this? So frustrating after everything else worked perfectly up to this point! Turns out a reboot fixed this issue...

I have another issue, I have downloaded a few movies through couch potato and they have been moved and renamed with no problems, but a couple have finished and are sitting in the downloads folder with no action from couch potato.

For one of the files I get this error in the CP logs: [tato.core.plugins.scanner] Couldn't find any movie files for xxxxxx 2013

I'm guessing that means in can't find relevant metadata for that file?

The other file I removed from transmission, seeing if that would have an effect, and now CP logs have the following error:

[tato.core.plugins.renamer] xxxxxxxxxxxxxx(tt1853739) not found in downloaders

I assume that means CP is checking the transmission status for that movie and seeing its no longer in transmission.

Both files are completed and sitting in my downloads folder, just not being renamed by CP. Is there an easy fix for this, or do I just need to manually rename and move these files myself. I'm guessing that once they are dealt with, they can be removed from the wanted section of CP, and that will stop CP from looking for them every minute in the downloader.

Thanks
 

dwhacks

Junior Member
Joined
Mar 27, 2014
Messages
18
I followed your guide and its been working pretty great. BUT I am having a weird issue that has happened 3 times now. When a movie is downloaded and renamed with CP I am able to see it and watch it like I should... for a few hours. I leave home and come back to the computer some time later and its gone, with no sign. Any ideas? I dont really know what it could be and where to look.

Heres a CP log, Its like it finds it after its already renamed it and removes it:

Code:
04-19 11:54:43 INFO [hpotato.core.plugins.base] Opening url: get http://www.omdbapi.com/?y=2013&t=pacific+rim, data: []
04-19 11:54:43 INFO [hpotato.core.plugins.base] Opening url: get https://api.couchpota.to/search/Pacific+Rim+2013/?limit=1, data: []
04-19 11:54:44 INFO [re.providers.info.omdbapi] Found: Pacific Rim (2013)
04-19 11:54:44 INFO [tato.core.plugins.scanner] Found 1 movies in the folder /media/movies/Pacific Rim (2013)
04-19 11:55:38 INFO [tato.core.plugins.renamer] Download of Pacific Rim 2013 BluRay 720p DTS x264-MgB completed!
04-19 12:42:48 INFO [otato.core.plugins.manage] Updating manage library: /media/movies04-19 12:42:48 INFO [hpotato.core.plugins.base] Opening url: get https://api.couchpota.to/search/Pacific+Rim+2013/?limit=1, data: []
04-19 12:42:48 INFO [hpotato.core.plugins.base] Opening url: get http://www.omdbapi.com/?y=2013&t=pacific+rim, data: []
04-19 12:42:48 INFO [re.providers.info.omdbapi] Found: Pacific Rim (2013)
04-19 12:42:49 INFO [tato.core.plugins.scanner] Found 1 movies in the folder /media/movies
04-19 12:42:49 INFO [hpotato.core.plugins.base] Opening url: get https://api.couchpota.to/info/tt1663662/, data: []
04-19 12:42:49 INFO [hpotato.core.plugins.base] Opening url: get http://www.omdbapi.com/?i=tt1663662, data: []04-19 12:42:49 INFO [re.providers.info.omdbapi] Found: Pacific Rim (2013)
04-19 13:05:38 INFO [hpotato.core.plugins.base] Opening url: get https://api.couchpota.to/search/Pacific+Rim+2013/?limit=1, data: []
04-19 13:05:38 INFO [hpotato.core.plugins.base] Opening url: get http://www.omdbapi.com/?y=2013&t=pacific+rim, data: []
04-19 13:05:38 INFO [re.providers.info.omdbapi] Found: Pacific Rim (2013)
04-19 13:05:39 INFO [tato.core.plugins.scanner] Found 1 movies in the folder /media/downloads
04-19 13:05:39 INFO [hpotato.core.plugins.base] Opening url: get http://www.omdbapi.com/?i=tt1663662, data: []
04-19 13:05:39 INFO [hpotato.core.plugins.base] Opening url: get https://api.couchpota.to/info/tt1663662/, data: []
04-19 13:05:39 INFO [re.providers.info.omdbapi] Found: Pacific Rim (2013)
04-19 13:05:39 INFO [tato.core.plugins.renamer] Same quality release already exists for Pacific Rim, with quality 720p. Assuming repack.
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim.srt"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim cd2.orig.txt"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim cd1.orig.nfo"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim.mkv"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Poster 3.jpg"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Poster 1.jpg"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Screen 09.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Screen 08.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Screen 10.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Screen 11.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Screen 05.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Screen 04.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Screen 03.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Screen 02.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Sample.mkv"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Screen 07.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Poster 2.jpg"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Screen 01.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Screen 06.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Box Cover.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim Screen 12.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim.orig.txt"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 08.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 09.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 03.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 12.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 02.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 10.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 04.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 05.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 07.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Box Cover 1.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Poster 1.jpg"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Poster 2.jpg"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 06.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 01.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 BluRay 720p DTS x264-MgB (Sample).mkv"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 11.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Box Cover 2.png"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Renaming "/media/downloads/Pacific Rim 2013 BluRay 720p DTS x264-MgB/Screens/Pacific Rim 2013 Screen 10.png" to "/media/movies/Pacific Rim (2013)/Pacific Rim 2013 Screen 10.png"
04-19 13:05:39 ERROR [tato.core.plugins.renamer] Couldn't move file "/media/downloads/Pacific Rim 2013 BluRay 720p DTS x264-MgB/Screens/Pacific Rim 2013 Screen 10.png" to "/media/movies/Pacific Rim (2013)/Pacific
Rim 2013 Screen 10.png": Traceback (most recent call last):
File "/usr/pbi/couchpotato-amd64/share/couchpotato/CouchPotatoServer/couchpotato/core/plugins/renamer/main.py", line 736, in moveFile
shutil.move(old, dest) File "/usr/pbi/couchpotato-amd64/lib/python2.7/shutil.py", line 301, in move copy2(src, real_dst) File "/usr/pbi/couchpotato-amd64/lib/python2.7/shutil.py", line 130, in copy2 copyfile(src, dst) File "/usr/pbi/couchpotato-amd64/lib/python2.7/shutil.py", line 82, in copyfile with open(src, 'rb') as fsrc: IOError: [Errno 2] No such file or directory: u'/media/downloads/Pacific Rim 2013 BluRay 720p DTS x264-MgB/Screens/Pacific Rim 2013 Screen 10.png'
 
04-19 13:05:39 ERROR [tato.core.plugins.renamer] Failed ranaming the file "Pacific Rim 2013 Screen 10.png" : Traceback (most recent call last): File "/usr/pbi/couchpotato-amd64/share/couchpotato/CouchPotatoServer/couchpotato/core/plugins/renamer/main.py", line 544, in scan self.moveFile(src, dst, forcemove = not self.downloadIsTorrent(release_download) or self.fileIsAdded(src, group)) File "/usr/pbi/couchpotato-amd64/share/couchpotato/CouchPotatoServer/couchpotato/core/plugins/renamer/main.py", line 736, in moveFile shutil.move(old, dest) File "/usr/pbi/couchpotato-amd64/lib/python2.7/shutil.py", line 301, in move copy2(src, real_dst) File "/usr/pbi/couchpotato-amd64/lib/python2.7/shutil.py", line 130, in copy2 copyfile(src, dst) File "/usr/pbi/couchpotato-amd64/lib/python2.7/shutil.py", line 82, in copyfile with open(src, 'rb') as fsrc: IOError: [Errno 2] No such file or directory: u'/media/downloads/Pacific Rim 2013 BluRay 720p DTS x264-MgB/Screens/Pacific Rim 2013 Screen 10.png' 04-19 17:05:38 INFO [hpotato.core.plugins.base] Opening url: get https://api.github.com/repos/RuudBurger/CouchPotatoServer/commits?per_page=1&sha=master, data: []


EDIT: is it my fault because I put the /media/movies folder in "Manage"? I think that might be it... D'OH!
 

Nayeem

Junior Member
Joined
Apr 1, 2014
Messages
20
just wondering if anyone knows how to fix this issue (see screen shot) my transmission shows a torrent I tried to download but the status is 710.7 kb of 1.63 GB (0.04%) and it’s stuck at that point. Above the torrent theres an error:

Error: Permission denied (/media/downloads/Captain America The Winter Soldier 2014 TS XviD MP3 MiLLENiUM/Sample.avi)

A little history on my setup and plugins:
Running freenas 9.2.0-Release-x64 (ab098f4)

Build FreeNAS-9.2.0-RELEASE-x64 (ab098f4)
Platform Intel(R) Pentium(R) CPU G3220 @ 3.00GHz
Memory 16323MB


I followed these instructions (excellent job btw!!) and have successfully installed, mapped each plugin to their respective folders. I created a jail for Plex, and then installed the following plugins from the directory - CouchPotato, Sickbeard, and transmission. I then also installed and connected the Transmission remote GUI.

I created a dataset labeled “Media” and within this I created a movies, series, music, photos, torrents, downloads folder. Permissions were automattically set to 0755 and this dataset is assigned to nobody:no group (although I’d like to change this later).

The error above seems like an obvious permissions issue but I can’t seem to figure it out. I checked via ssh the folder in question “media/downloads” - they were 755. I changed them to 777 but it still returned the same error. Any ideas or suggestions on what I should do??

Thanks in advance!
 

Attachments

Status
Not open for further replies.
Top