FreeNAS-8.0.1-BETA4

Status
Not open for further replies.
J

jpaetzel

Guest
I'm pleased to announce the availability of FreeNAS 8.0.1-BETA4

https://sourceforge.net/projects/freenas/files/FreeNAS-8.0.1/

Release Notes for 8.0.1-BETA4

This is the last BETA planned for the 8.0.1 release cycle.
This line was present in the BETA3 release notes as well. BETA3
contained several fairly significant bugs, and a patch release was
planned to address them, unfortunately due to a myriad of issues that
patch release was delayed enough that doing another beta made more sense
than any sort of patch.


*** IMPORTANT ***

The image size increased in 8.0.1-BETA3. The new size requires a 2 GB
storage device. The GUI upgrade can be used to upgrade a system from
BETA3 to BETA4, but upgrades from previous releases can only be done
from the CD. The other option is to save the config, reinstall the new
version, then restore the config.

Changes since 8.0.1-BETA3:

- ACLs and UNIX file system permissions work properly on both UFS and
ZFS volumes. Because the ACLs needed by windows and UNIX are mutually
exclusive the GUI now prompts for which system you will be using and
sets permissions appropriately.

- Changes to link aggregations which resulted in a regression in
functionality have been reverted. There was a workaround to the issue
in BETA3. A migration has been added to the system to clear the
workaround. If you are upgrading from something other than BETA3 you
don't need to do anything. If you are upgrading from BETA3, and BETA3
broke your link aggregations BETA4 will fix things. If BETA3 broke your
link aggregations and you applied a workaround the migration should
revert the workaround and things will work properly. If upgrading to
BETA4 causes link aggregations to stop working the best solution is to
delete and recreate them.

- BETA3 completed the change from hard wiring device names in the
database to using identifiers. iSCSI device extents were not changed
properly. This BETA addresses that issue.

- A method was accidentally deleted from the middleware that prevented
smartd from running. This has been resolved.

- ZFS snapshots are now exported to CIFS shares and are visible in
windows as shadow copies. How you access these varies between windows
version.

- Many improvements have been made to replication that increase it's
speed and robustness.

- The CD upgrade now preserves all of /data instead of select files.

- Fix a bug in the graph generation script which would allow the graphs
of deleted volumes to persist.

- Fix a bug in UFS volume creation, where newly created UFS volumes
would only show after a reboot.

- Add tmux to the system. Just like GNU screen in functionality only
BSD licensed and actively maintained.

- Add dmidecode to the system. This can provide very useful hardware
diagnostic information.

- Updated the version of Intel NIC drivers to handle Intel's latest
round of hardware.

- Add support for Marvell MX2 SATA controllers, sold with some WD 3TB
drives.

- Make netatalk (AFP) compatible with OS X 10.7

Filename:
FreeNAS-8.0.1-BETA4-amd64-Full_Install.xz
SHA256 Hash:
5b3964255f67802fd2926bfd70352471c033da43c61489f567452762c3b9bd67

Filename:
FreeNAS-8.0.1-BETA4-amd64-GUI_Upgrade.xz
SHA256 Hash:
926faf4616f5e246bdfb9532104e43ef77f866105c8d27416a6031525637010d

Filename:
FreeNAS-8.0.1-BETA4-amd64.iso
SHA256 Hash:
383ba369426211fb9a4f47a28ccd9246a4136e156b7463dd56a50520e1ff3db4

Filename:
FreeNAS-8.0.1-BETA4-i386-Full_Install.xz
SHA256 Hash:
53b3ef6faea5240253c0633eb2875f3542008c43aebf0df03c0ff9ec6c768b72

Filename:
FreeNAS-8.0.1-BETA4-i386-GUI_Upgrade.xz
SHA256 Hash:
aa2b8d689df8c72bff0f12b0cb1b694219c2874713dadb916db151c3aa9d5540

Filename:
FreeNAS-8.0.1-BETA4-i386.iso
SHA256 Hash:
805beed2368aaafb9699abbe3ea05a5444ff6765be7427f45e3d8438a72dadf7
 

Tekkie

Patron
Joined
May 31, 2011
Messages
352
About to gold boldly where no man has gone before... upgrade running...

PS. Upgrade takes its sweat time to run and will reboot your box without asking ;)

smartd still fails to start :( ... ok this is weird after enabeling SMART on one of my drives and changing the power mode, smartd started happily.
 

Couch Potato

Dabbler
Joined
Jun 22, 2011
Messages
15
Just out of interest whats the build numer of BETA4? - I'm currently building 6956 from source...

Ta!

Andy B.
 

cbray

Explorer
Joined
Jun 16, 2011
Messages
68
Shark week ?

Does the Discovery Channel know you started 'Shark Week' early ?

Congrats on reaching BETA-4

CB
 
B

Bohs Hansen

Guest
Looking forward to testing beta4 and the ACL's. Tried giving the latest .7.2 version a chance yesterday, but that doesn't detect my LAN card .. :) Thanks again to the devs for their work (can't hurt to say :))

[edit]
Fresh install of FreeNAS-8.0.1-BETA4-amd64.iso and I can't start any services. I get "The service could not be started" every time. Anyone else getting this?
 

marcusmarcus

Explorer
Joined
May 27, 2011
Messages
89
SNMP is no longer sending me reports to my email address. It worked fine in the 8.0 release, not sure which beta caused it to stop, just noticed it though. I go into settings>email and all settings in there are correct, click "Send Test Mail" and it does send to my email. Went to SNMP settings and it does have the right email address. Tried to change the email address in SNMP settings to another email and I get a message "The contact must contain only alphanumeric characters, _ or -". I removed the "@" symbol and still get that message. Put the symbol back and removed the "." and still get that message. Removed the "@" symbol and the "." and it saved the settings now. Went back in and tried to change back to my email address and I get the message again, wont let me put in an email address. Tried rebooting and still having the same issue. The SNMP service starts and stops without issue on the services tab. Anyone know how to fix this?
 

William Grzybowski

Wizard
iXsystems
Joined
May 27, 2011
Messages
1,740
Looking forward to testing beta4 and the ACL's. Tried giving the latest .7.2 version a chance yesterday, but that doesn't detect my LAN card .. :) Thanks again to the devs for their work (can't hurt to say :))

[edit]
Fresh install of FreeNAS-8.0.1-BETA4-amd64.iso and I can't start any services. I get "The service could not be started" every time. Anyone else getting this?

Did you try clearing the browser cache? Or even with another browser?
 
B

Bohs Hansen

Guest
Did you try clearing the browser cache? Or even with another browser?

i didn't try clearing the cache in firefox (cause of all the "keep login'd"), but i did try in internet explorer 8 cause i never used that for freenas before. As said, i installed it from the new iso and not an upgrade.
 

jim82

Dabbler
Joined
Jul 5, 2011
Messages
44
Permissions still fails for me:

Doing this:
s1.jpg


Results in this:


s2.png


EDIT: Upgraded via GUI from BETA3, Firefox cache cleared.
EDIT2: Seems like when above operation is performed, it sets some default permissions -> drwxr-xr-x+
EDIT3: Ticket created https://support.freenas.org/ticket/518
 

binarypower

Dabbler
Joined
Jun 18, 2011
Messages
10
Hmm, cant seem to update from BETA3 to BETA4 using the web browser. It uploads the file and the button says "please wait" the footer says

Jul 14 10:43:21 freenas kernel: re0: link state changed to UP
Jul 14 10:43:21 freenas freenas[1377]: Popen()ing: sysctl -b kern.geom.confxml
Jul 14 10:43:21 freenas ntpd[1483]: ntpd 4.2.4p5-a (1)
Jul 14 10:43:21 freenas kernel: fuse4bsd: version 0.3.9-pre1, FUSE ABI 7.8
Jul 14 10:43:22 freenas mountd[1153]: can't open /etc/exports
Jul 14 10:43:22 freenas mountd[1153]: can't open /etc/exports
Jul 14 10:43:55 freenas freenas[1686]: Executing: /bin/rm -rf /var/tmp/firmware
Jul 14 10:43:55 freenas freenas[1686]: Executing: /bin/mkdir -p /mnt/Storage/.freenas
Jul 14 10:43:56 freenas freenas[1686]: Executing: /usr/sbin/chown www:www /mnt/Storage/.freenas
Jul 14 10:43:56 freenas freenas[1686]: Executing: /bin/ln -s /mnt/Storage/.freenas /var/tmp/firmware

...but then it sits there. I'm using the FreeNAS-8.0.1-BETA4-amd64-GUI_Upgrade.xz firmware with the correct hash. I havnt been able to web update from 1-2-3 and now 4. Has anyone been able to web update? Whats the trick?
 

jim82

Dabbler
Joined
Jul 5, 2011
Messages
44
Worked for me, the web upgrade. Also from BETA3 amd64. It took a while though.

Hmm, cant seem to update from BETA3 to BETA4 using the web browser. It uploads the file and the button says "please wait" the footer says



...but then it sits there. I'm using the FreeNAS-8.0.1-BETA4-amd64-GUI_Upgrade.xz firmware with the correct hash. I havnt been able to web update from 1-2-3 and now 4. Has anyone been able to web update? Whats the trick?
 

louis-m

Dabbler
Joined
Jun 7, 2011
Messages
34
did a fresh install. all looks well to me at the moment.

for anybody using vlans......
1. initial bootup and create vlan (this will be the vlan that sets the default route that freenas uses for ad etc)
2. now configure interface <vlan>

the first configured interface will set the default route so in my case the first vlan set the default route via its dhcp lease from the vlan. the physical interface does not have an ip set.
the default route is important if you try and set active directory. when trying to change it in previous releases, the default route didn't work and ad wouldn't authenticate.
after the first interface is set, i can now configure my other vlans and join ad.

active directory works fine. i still can't see the issue with unix/windows permissions as mine appears to work fine using unix as the base permissions.

initial testing looks good although its only the first impression.
 

jim82

Dabbler
Joined
Jul 5, 2011
Messages
44
J

jpaetzel

Guest
6953 was the last rev merged from trunk that is in the tag. The merge itself is r6954. r6955 removed a legacy freenas 7 file that snuck in to the tree, and 6956 was a slight improvement to replication. So essentially you are running B4.
 

fortyhands

Cadet
Joined
Jul 7, 2011
Messages
6
Performed full install and everything's working great.

Wasn't able to perform the upgrade. "Invalid checksum" or something. Performed full install instead.

Set up all of my SMART tests and reporting. Email reporting working fine, Mac and windows shares working well. Write speeds ~65Mbps. RAM usage peaks at 6Gb (8Gb installed)

Awesome!!! Thanks again for all of your hard work!

Now trying to figure out how to set up my tomato router for remote SSH access so I can access this NAS from work...
 

jim82

Dabbler
Joined
Jul 5, 2011
Messages
44

pauldonovan

Explorer
Joined
May 31, 2011
Messages
76
i didn't try clearing the cache in firefox (cause of all the "keep login'd")

Clearing a browser's cache does not remove your "keep me logged in" settings at your favourite sites if that's what you mean. Clearing *cookies* would do that.

Paul
 

ProtoSD

MVP
Joined
Jul 1, 2011
Messages
3,348
Same problem I had with beta-3.

First tried upgrade from CD and it seemed to go well, but failed part way thru boot.

Next tried clean install from CD, seemed to go well again, but failed again.

Using 2GB flash drive, which worked with beta-2

See attached screenshot:

boot-fail-beta4-2.jpg

UPDATE: Tried dd/zero drive, formatting it, installing Ubuntu (successfully this time), but still the same problem with FreeNAS. Updated attachment also.

UPDATE-2: Well contrary to the official install video demonstrating how to install FreeNAS using VMware here: http://www.youtube.com/user/FreeNASTeam#p/u/5/geD3mf_kAaY
I burned a physical CDR and installed beta-4 to the same (erased) flash drive above. Immediately after the install I went into the shell and did a 'gpart show ada2' and the partitiions and correct disk size were displayed. After trying to boot again from the flash I got the same error. I'm posting an additional screenshot from this boot with a different 'gpart' result.

boot-fail-beta4-3.jpg
 

Couch Potato

Dabbler
Joined
Jun 22, 2011
Messages
15
6953 was the last rev merged from trunk that is in the tag. The merge itself is r6954. r6955 removed a legacy freenas 7 file that snuck in to the tree, and 6956 was a slight improvement to replication. So essentially you are running B4.

Thanks for the info...

Andy B.
 
Status
Not open for further replies.

Similar threads

J
Replies
52
Views
24K
J
Replies
42
Views
25K
Joshua Parker Ruehlig
J
J
Replies
20
Views
15K
Top