Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Truenas corruption jails

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

xames

Member
Joined
Jun 1, 2020
Messages
178
Every day my jails are corrupted over TrueNas beta, how i could know why this happened? What logs i have to look?

Thanks.
 

Ericloewe

Not-very-passive-but-aggressive
Moderator
Joined
Feb 15, 2014
Messages
17,013
What do you mean "corrupted"? In what way?
 

xames

Member
Joined
Jun 1, 2020
Messages
178
Jails State Corrupt

I think its something realted on pool scrub, but i don't know what because status show 0 errors. And the problem is after Corrupt state, i cannot revert it with snapshots i don't know why too, i'm so new here, please help.

Yesterday i recreate 3 jails perfect, and this morning 3 are corrupt state.

"mynamejail" is missing it's configuration, please destroy this jail and recreate it.

The pool are inside and SSD disk.
 
Last edited:

xames

Member
Joined
Jun 1, 2020
Messages
178
truenas# iocage list


dnsmasq is missing it's configuration, please destroy this jail and recreate it.
graylog is missing it's configuration, please destroy this jail and recreate it.
nextcloud is missing it's configuration, please destroy this jail and recreate it.
+-----+-----------+---------+---------+-----+
| JID | NAME | STATE | RELEASE | IP4 |
+=====+===========+=========+=========+=====+
- | dnsmasq | CORRUPT | N/A | N/A |
+-----+-----------+---------+---------+-----+
| - | graylog | CORRUPT | N/A | N/A |
+-----+-----------+---------+---------+-----+
| - | nextcloud | CORRUPT | N/A | N/A |
+-----+-----------+---------+---------+-----+
 

c77dk

Member
Joined
Nov 27, 2019
Messages
161
what hardware are you using? Is this a new system, or one upgraded from 11.x ?
 

waqarahmed

iXsystems
iXsystems
Joined
Aug 28, 2019
Messages
86
@xames can you please create a ticket at https://jira.ixsystems.com and kindly make sure to attach a debug of the system ( System -> Advanced -> Save Debug ). It would be nice if you could document when you started having these issues and if you introduced some other changes at around that point which might have been a factor. Thank you
 

xames

Member
Joined
Jun 1, 2020
Messages
178
It's a new system Hp microserver gen10 with 24gb ram and 2 ssd and 1 sata drive. I send debug later, i try to install freenas there but not possible, only truenas beta new one.
 
Last edited:
Top