Problems with getting run FreeNAS - status: 4

Not open for further replies.


Aug 2, 2018
Hey there!

About one month ago I had to plan and carry on the splitting of two companies - the one I am in needed an own infrastructure with Firewall, AD, Storage- & Backup-System and so on.

So with FreeNAS I found exactly what I was looking for my backup & storage-strategy and I bought a server for my plans:
- 1x Intel Xeon Silver 4112 (2,60GHz, 4-Core, 8,25MB)
- 4x 8 GB (1x 8192 MB) ECC Registered (RDIMM) DDR4 2400 RAM 1 Rank (ATP Premium)
- 1x Supermicro Mainboard X11SPL-F
- 8x 10 TB SAS III HGST Ultrastar He10 3,5" 7.2k (512e)
- 1x 1 TB Samsung 960 PRO (M.2 PCIe x4 2280)
- 1x Broadcom (LSI/Avago) MegaRAID 9361-8i SAS3 8x intern
- 1x Intel 10 Gigabit X550-T2 RJ45 Dual Port network card

With the MegaRAID I realized a Raid6 with 2 Hotspares so I've got ~54TB Volume for all the data and backups we want to place there.

FreeNAS 11.1 downloaded - compared the SHA256 checksum - all green.
Burned to Bootable USB-Stick and installed (UEFI) on the 1TB Samsung Pro PCIe without any errors.

In my network the server get's three IP-adresses via DHCP-Server bound to there MAC-Adresses:
- LAN1
- LAN2

Server is pingable - Webgui is reachable - Installwizard could be completed > no errors.
Update-Check passed the latest version is already installed.
Install verify is also successfully.

The first thing I saw is the yellow-warning 'smartd_daemon is not running'.
The services > control services-page is loading without an ending and every manual try to start the daemon via console ends with 'freenas smartd[12772]: Unable to register device /dev/da1 (no Directive -d removable). Exiting.'

Also almost all the locations I try to go e.g.
- Storage > Volumes 'Unable to load /api/v1.0/sotrage/volume/?parent=null status: 416'
- Network > Interfaces 'Unable to load /api/v1.0/network/interface/?parent=null status: 416'
- System > Boot 'Unable to load /api/v1.0/system/bootenv/?parent?=null status: 416'
- Tasks > Cron Jobs 'Unable to load /api/v1.0/tasks/cronjob?parent?=null status: 416'
end up with the status 416.

I've found this thread to the 416 status:

So I tried to connect to the WebGUI from other clients in and out my network different browsers different hardware.
The webinterface won't get shown correctly from any other client except my two identical notebooks I'm working with but where I'm getting the status: 416...
I'm a bit confused about that and don't really know how I can handly this.

I've tried an upgrade and also fresh install of FreeNAS 11.2 Beta 2 but this ended with a pingable server and a loading blue screen which tells me 'Connecting to NAS ... Make sure the NAS system is powered on and connected to the network'.
While booting it doesn't shows any errors.

So whatever I'm doing regardless of the version of FreeNAS I'm not able to start configure certainly not using this great software...

Does anyone may have an idea which could help me?

Thanks a lot!

Best regards ~


actually does care
Feb 6, 2014

I'm going to be blunt, you have made a couple bad hardware choices, one being particularly grievous. Thankfully it sounds like you're early enough in the installation process that we can stop you from anything really bad happening.

1x Broadcom (LSI/Avago) MegaRAID 9361-8i SAS3 8x intern

See this? This is a RAID card.

Take it out back and shoot it. (Or return it to the point of purchase, if that's an option.)

Then purchase an LSI 9300-8i host bus adapter (HBA) and update its firmware to the newest revision. Don't use a hardware RAID controller with ZFS if you value your data at all.

Most important thing done here.

Next up, that's a 1TB NVMe SSD - if you use it as a boot device, it won't be usable for any other purpose within the machine. It lacks the power-loss-protection measures to be a viable SLOG device, so at best it could be an L2ARC (read cache) device - but 1TB of L2ARC is far too much to assign to a machine with only 32GB of RAM in my opinion. Buy a matched one and create a mirrored high-performance datastore, or return it and we can find a better-suited drive to your needs, be that a high-performance SLOG for writes, or perhaps (much) more RAM for reads.

Once that's done, we can move on to troubleshooting your boot issues.
Not open for further replies.