Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Kritieke fout op een HDD

Status
Not open for further replies.

Shadöpansä

Neophyte
Joined
Jun 10, 2016
Messages
10
Beste,

Heb een probleem met mijn Freenas. Sinds 4 juli geeft ze het volgende aan:

  • KRITIEK: 4 juli 2017 16:42 - Device: /dev/
    Code:
    ada1
    , 4 Currently unreadable (pending) sectors
  • KRITIEK: 4 juli 2017 16:42 - Device: /dev/ada1, 4 Offline uncorrectable sectors
Ik heb het opgezocht maar kwam er nog niet echt uit wat het nu precies is. Maar ik heb wel het mogelijke gedaan wat ik op de oude forums heb gelezen. Ik heb al een long smart test gedaan, die precies 155 minuten duurde met de volgende command:

smartctl -t long /dev/ada2

en toen gekeken naar de test results met:

smartctl -a /dev/ada2

Zie bijlage:
free.PNG


Maar ik heb dus begot geen idee waar ik moet naar kijken.. en hoe ik dit mogelijk kan oplossen, en of het überhaupt nog fixbaar is? Want ik wil niet graag al mijn data verliezen en maak me toch wel zorgen hierom. Iemand enigszins ervaring, met dit soort kritieken meldingen op schijven? Dan hoor ik het graag van je!


Vriendelijke groet,

FB
 
Last edited:

DrKK

FreeNAS Generalissimo
Joined
Oct 15, 2013
Messages
3,630
I'll answer you in English, since I know 99.91398182% of people in the Netherlands can speak English just fine sir.

Your problem is that you have a failing hard drive that needs to be replaced. It would appear that the probable reason for this drive failing is that you have an ABSOLUTELY ASTONISHING 186613 Load Cycles in only 4800 hours of disk use. That means that you're loading the disk every 90 seconds or so. The only case I'm aware of where that's possible is if you're using Western Digital green/blue drives, which are not recommended.

Perhaps sir, if you would pastebin the *ENTIRE* output of smartctl -x -qnoserial /dev/ada1, we can assess how bad your situation is, but your drive appears to be failing.
 

DrKK

FreeNAS Generalissimo
Joined
Oct 15, 2013
Messages
3,630
Also sir, your bad drive is ada1, not ada2. You did the SMART test on the wrong drive.
 

Shadöpansä

Neophyte
Joined
Jun 10, 2016
Messages
10
Hello,

I feel really bad now, that i didn't think this true when i was building the NAS.
i got one Western Digital Black, 1TB. And one, i thought Seagate, 1.5 TB. In there. And i was looking wrong with the test than. Well i did a short smart test on ada1 and
this is the Result:

ada11.PNG


Result: smartctl -x -qnoserial /dev/ada1:

ada1 full diagnostic.PNG


And i don't know how to pastebin the entire output of it in the Shell.. it wont let me.

kind regards,

FB
 
Last edited:

styno

Senior Member
Joined
Apr 11, 2016
Messages
459
Hey, het gaat inderdaad over ada1 en niet over ada2.
Je kan de output van smartctl -a /dev/ada2 op het forum pasten tussen zogenaamde 'code' tags,
Kan je ook de output van zpool status pasten? Als ik het zo zie zou het best kunnen dat je op termijn best beide drives zal moeten vervangen.
 

Shadöpansä

Neophyte
Joined
Jun 10, 2016
Messages
10
I will do a full smart test on ada1 now. I wil post the results later.

Result: smartctl -t long /dev/ada1

Pic coming soon..

this is the Zpool status:

zpool.PNG
 
Last edited:

styno

Senior Member
Joined
Apr 11, 2016
Messages
459
Okay, English it is...

The way I see it, you are about to lose your pool. You have two unhealthy disks in a striped configuration. (I am missing a mirror or raidzX entry in the zpool status).
First thing to do is backup your data, right now.

ps. you don't need to paste pictures, you can select the text, right click/copy and paste it here between CODE tags to keep the formatting.
 

Shadöpansä

Neophyte
Joined
Jun 10, 2016
Messages
10
Hi,

I did a long smart test the hole night, but i can't get the results. I only get the short result of 5 minutes with smartctl -a /dev/ada1, when it basically did the whole night long smart testing ada1. Can you tell me what the code is, for seeing the hole smart test??

And yes, a year ago i only did a striped configuration and nothing more. I will backup my data soon. I was going to build a another NAS anyway, and then i will put WD Red in it, with mirror or raidzX config. I don't know which is better yet.. can you tell me?? Too bad for for these 2 drives, the WD black was only a year old when i bought it, and build it with, maby i get still warranty on it. For the seagate drive i'm not so sure.
 

styno

Senior Member
Joined
Apr 11, 2016
Messages
459
Ah, living on the raid-0 edge...
You indeed see the smart test results with smartctl, if the result is not there it means it's still running. (and something is really wrong with the drive)

With code tags, we mean this:
upload_2017-7-7_16-56-46.png


ps: You can check your warranty online on the WD site.
 

Shadöpansä

Neophyte
Joined
Jun 10, 2016
Messages
10
How do you mean only smartctl? then i not getting anything.. isn't there a smart code to see the long result??

And also i want to paste the full result, but i can't get the whole text. Because i can't scroll to above in the shell, to copy everything it says on it. Do you know how to get it all?
 
Status
Not open for further replies.
Top