Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

collectd hogging RAM?

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

danb35

Wizened Sage
Joined
Aug 16, 2011
Messages
12,258
I updated my main FreeNAS server (on 11.3-Usomething) to TN 12.0-U1 a couple of weeks ago. Everything in general seems to be working fine--jails work, sharing works, the GUI works, no big surprises. Except...

I logged into the GUI yesterday morning and was surprised to see this:
1609591617539.png

That's pretty unusual; with prior releases I'd expect the numbers for "ZFS Cache" and "Services" to be roughly reversed. htop indicates that collectd is consuming huge amounts of RAM, far more than any other process:
1609591735405.png


I can't show any data from the Reporting pages, as they don't work--seems that's a 12.0 bug yet to be fixed. What's up with this?
 

ornias

Neophyte Sage
Joined
Mar 6, 2020
Messages
1,461
I think 66G is a little bit excessive for collectd... Maybe file a bug report.
 

danb35

Wizened Sage
Joined
Aug 16, 2011
Messages
12,258
Makes sense. https://jira.ixsystems.com/projects/NAS/issues/NAS-108865

It wouldn't let me attach the debug file, though, saying it was too large--I expect I'll still need to work on that. Edit: Well, found the spot in the GUI (System -> Advanced), but it isn't letting me save a debug file:
1609605704364.png


Edit 2: Well, freenas-debug -A saved a 348 MB text file. It bzips to 15 MB, though, so that can be uploaded.
 
Last edited:

adrianwi

Neophyte Sage
Joined
Oct 15, 2013
Messages
1,191
I've seen a similar issue with the RAM used by Services increasing over time and rebooted yesterday to try and help identify the problem.

On FreeNAS 11.3-U5 my Services were using ~20GB RAM, but on TrueNAS 12.0-U1 after things have settled from a restart it's reporting around 24GB. Before I restarted it had grown to almost 35GB in a couple of weeks since upgrading.
 
Top