Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

ZFS Pool Degraded (too many errors)

Status
Not open for further replies.

Stekelenburg

Junior Member
Joined
Jul 3, 2013
Messages
14
Beste,

Niet al te lang geleden heb ik mijn FreeNAS een opfrisbeurt gegeven door mijn oude schijven te vervangen door een nieuw aangeschafte WD Red 3Tb (inmiddels tevens een 1Tb aan toegevoegd), m'n oude werkgeheugen van 2 x 4Gb te vervangen door 2 x 8Gb en de laatste versie van FreeNAS (9.3-STABLE) te installeren. Echter kreeg ik al vrij snel de melding dat m'n ZFS pool 'degraded' (zie hieronder) was. In beginsel ging het slechts om een paar errors, welke ik handmatig heb verholpen door de betreffende files te vervangen, echter haalde dit niets uit en krijg ik alleen maar meer errors. Als gevolg hiervan ontvang ik continue foutmeldingen tijdens kopieeracties en heb ik te maken met bestanden, die niet meer te benaderen zijn.

Kan iemand mij vertellen wat hier aan de hand is en wat de oorzaak van mijn probleem is? Wordt dit bijvoorbeeld veroorzaakt door m'n nieuwe WD Red 3Tb schijf, welke 'bad sectors' o.i.d. bevat en moet ik hiermee terug naar de winkel of moet ik de oorzaak ergens anders zoeken!?

N.B. Probleem deed zich eigenlijk direct voor na het plaatsen van de nieuw aangeschafte WD RED HD, heb er vervolgens een 2de 1Tb schijf aan toegevoegd om te kijken of dit effect had, maar helaas...

Bij voorbaat dank voor jullie reactie/hulp :)

Systeeminformatie.png


ZFS Pool Degraded.png
 
Last edited:

Rilo Ravestein

Neophyte Sage
Joined
Mar 6, 2014
Messages
685
Kun je de hele hardware setup geven en hoe zag je vorige setup eruit? Verder zie ik dat van de "nieuwe" schijf al de helft vol staat, klopt dat? Kun je de output van smartctl -a /dev/ada# posten voor elk van je drives (# vervangen door het nummer van de drive, bijvoorbeeld 0 en/ of 1), hieruit zou wat meer info moeten komen.
Je gebruikt maar 1 disk, geen redundantie, ik neem aan dat je voor de belangrijkste data een backup hebt gemaakt?

EDIT: Ik zie dat je ook al in het Engelstalige gedeelte de vraag hebt gesteld. Goed idee, daar heb je meer mensen die je kunnen helpen (en zeker sneller) dan hier meestal. :)
 

theo

Neophyte
Joined
Jan 31, 2014
Messages
10
Goedendag,

Ik heb sinds kort een zelfde probleem.
Het begon met 3x de onderstaande melding:

Checking status of zfs pools:
NAME SIZE ALLOC FREE EXPANDSZ FRAG CAP DEDUP HEALTH ALTROOT
Data 2.72T 1.75T 990G - 14% 64% 1.00x ONLINE /mnt
freenas-boot 7.25G 1.03G 6.22G - - 14% 1.00x ONLINE -

pool: Data
state: ONLINE
status: One or more devices has experienced an error resulting in data
corruption. Applications may be affected.
action: Restore the file in question if possible. Otherwise restore the
entire pool from backup.
see: http://illumos.org/msg/ZFS-8000-8A
scan: scrub repaired 0 in 7h31m with 1 errors on Tue May 19 04:26:45 2015
config:
NAME STATE READ WRITE CKSUM
Data ONLINE 0 0 1
mirror-0 ONLINE 0 0 2

gptid/8e7f7d83-8bfb-11e3-ad68-6805ca1c9de8 ONLINE 0 0 2
gptid/8f5cd12a-8bfb-11e3-ad68-6805ca1c9de8 ONLINE 0 0 2

errors: 1 data errors, use '-v' for a list

-- End of daily output --

Ik heb 2x een lange smarttest uitgevoerd. Bij de 1e kreeg ik geen melding en bij de 2e (1 nacht later) kreeg ik onderstaande melding.
"De status van volume Data (ZFS) is DEGRADED: One or more devices has experienced an error resulting in data corruption. Applications may be affected."

Wat is er aan de hand en wat kan ik er aan doen?
Iemand een suggestie?
 

Rilo Ravestein

Neophyte Sage
Joined
Mar 6, 2014
Messages
685
Je schijf lijkt een probleem te hebben. Voordat je ook maar iets anders onderneemt moet je eerst gelijk zorgen dat je een back-up maakt, van ten minste je belangrijkste data.
Edit: Ik zie dat het om je boot device gaat, zo te zien heb je een Mirror? De foutieve drive vervangen dus.
 

theo

Neophyte
Joined
Jan 31, 2014
Messages
10
ik heb inderdaad mirror. Bij het commando zpool status -v gaf hij aan dat er een probleem is met de spool van de backupjail.
Verder in gekeken en hier stonden veel bestanden omtrent mail die hij niet kon versturen???
Deze heb ik verwijderd en hij is nu bezig met het reinigen van de schijven.

Bij de smartctl -a /dev/ada0 en ada1 geeft hij aan dat beide schijven goed zijn.
Ook is de schijf nog steeds benaderbaar en lijkt er niets aan de hand.

Morgenochtend maar eens controleren hoe de scan is verlopen.
 

Rilo Ravestein

Neophyte Sage
Joined
Mar 6, 2014
Messages
685
Het ziet er naar uit dat zowel (één van) de boot device(s) een fout heeft als (één van) je normale harde schijven. Zoek maar eens een beetje rond hier, met name in het Engelstalige gedeelte. Deze melding en wat je hiermee moet doen is al heel vaak besproken.
 

theo

Neophyte
Joined
Jan 31, 2014
Messages
10
Sinds een paar dagen heb ik hetzelfde probleem als hierboven beschreven.
Na het uitvoeren van zpool status -v krijg ik deze melding.
pool: Data
state: ONLINE
status: One or more devices has experienced an error resulting in data
corruption. Applications may be affected.
action: Restore the file in question if possible. Otherwise restore the
entire pool from backup.
see: http://illumos.org/msg/ZFS-8000-8A
scan: scrub repaired 768K in 12h40m with 1 errors on Sun Jan 24 12:40:35 2016
config:

NAME STATE READ WRITE CKSUM
Data ONLINE 0 0 0
mirror-0 ONLINE 0 0 0
gptid/8e7f7d83-8bfb-11e3-ad68-6805ca1c9de8 ONLINE 0 0 0
gptid/8f5cd12a-8bfb-11e3-ad68-6805ca1c9de8 ONLINE 0 0 0

errors: Permanent errors have been detected in the following files:

Data/Media/Films:<0x2067>

pool: freenas-boot
state: ONLINE
status: One or more devices are configured to use a non-native block size.
Expect reduced performance.
action: Replace affected devices with devices that support the
configured block size, or migrate data to a properly configured
pool.
scan: scrub repaired 0 in 0h3m with 0 errors on Sat Jan 30 03:48:57 2016
config:

NAME STATE READ WRITE CKSUM
freenas-boot ONLINE 0 0 0
da0p2 ONLINE 0 0 0 block size: 512B configured, 8192B native

errors: No known data errors

Het gaat denk ik de regel die in midden staat.....Data/Media/Films:<0x2067> maar wat betekent ik heb geen idee.
Kan iemand mij vertellen wat ik kan doen.
 

WBos

Junior Member
Joined
Feb 25, 2016
Messages
18
Zomaar even tussendoor.. heb je ECC geheugen gebruikt?
Het lijkt namelijk op een Memory issue waar iedere keer een bit verkeerd komt, en door het scrubben, onderhoud je zpool steeds slechter gaat worden, ik ben bang dat als het zo door gaat, je alle data namelijk op je buik kunt schrijven.
 
Status
Not open for further replies.
Top