Problems running qBittorrent in a jail


Aug 9, 2017
I've just installed qBittorrent following the instructions here, including the autostart script. It seems to have worked, but I'm having problems with logins and settings.

Problem 1: downloads show peers but stall out almost immediately
Problem 2: qBittorrent seems to have lost and then found its settings, alternately showing my settings/user ID changes and then reverting to defaults/clean settings
Problem 3: web UI sometimes won't load when I try to access it using its IP address - message "refused to connect" in the browser
Problem 4: I'm IP locked for failed login attempts, despite definitely using the correct credentials

Long version:

I first logged in with the default ID and pass (admin, adminadmin). I changed these, storing the new details in KeePass. I then set up a watch folder and default download directory in one of my preexisting shares. This seemed to be working OK, as .torrents were spotted and started as expected. However, every single one of them, whether or not it initially showed any peers and whether or not it started to download any data, quickly changed to "stalled" status.

At this point the program or the web UI seemed to bug out. I refreshed the page and was prompted to log in again, which I tried using the credentials I'd stored earlier. This failed but the default admin ID worked: my settings seemed to have been wiped and none of the test torrents were visible. I set the same new ID and pass as before, then qBit seemed to stop responding and the web UI reported that the server was unreachable. I restarted qBit from the command line and logged back into the UI with my new ID and pass: my torrents were visible again, even though I'd not recreated them during the last login.

At this point the UI stopped responding again so I restarted the jail. I tried to log in with the new ID, which failed, and then the default ID, which also failed. There is no way that I got either set of creds wrong (I was using drag and drop from KeePass). I tried 3-4 times with a combination of both sets of creds and then the UI told me my IP had been banned for failed login attempts

Next I tried accessing the UI from my laptop, assuming that its IP would be clean. The qBit UI "refused to connect", according to Chrome. It was still responding on my desktop (though I was still locked). Shortly after this something went odd somewhere (probably a LAN issue) and my SSH connection to the NAS died, as did the web UI. When I was able to reconnect, the qBit UI started refusing to connect to the desktop as well as the laptop. I reconnected with SSH, confirmed that the qBit process was still running, killed and restarted it and tried the UI again with no more luck: the qBit IP address responds to ping and FreeNAS is still working, but the qBit UI is inaccessible (and even if I could get it to work, I probably still couldn't log in.

On top of this, something deleted all of the .torrent files in the watch folder, even though none of them were completed (I don't recall if my settings were to keep completed .torrents or delete them). I suspect it's the result of confusion between the default settings and configured settings that the UI was presenting me with.

Can anyone advise me on any of these problems? Thanks in advance.
Feb 24, 2013
Exact same issues here as regard logon credentials. Seems to reset itself to default logon and password each time, and only allows me to connect again after 15 minutes or so of my browser saying no connection.

Tried wiping the stored passwords in Chrome, no effect. Tried another browser, no effect. Looks like a bug.

I'm using Freenas 11.2