Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

MacOS Mojave and FreeNAS 11.1-U6/11.2-RELEASE

nikbok

Neophyte
Joined
Mar 16, 2019
Messages
6
No errors or other problems logged on Mac side.
On FreeNAS I get this on log.smbd with debul level.
 

Attachments

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
7,072
Well, nothing stands out to me there. I can check for differences in our lab sometime next week. Try turning off Catia as well and set log level to minimum. If you encounter an error it should log at low level. As it stands, the error might be getting wiped out when the log rolls over. Be sure to restart samba after making changes.
 

nikbok

Neophyte
Joined
Mar 16, 2019
Messages
6
Unfortunately, catia=off did not help

Changed log level and waiting for errors... thanx for help.
 

nikbok

Neophyte
Joined
Mar 16, 2019
Messages
6
It is possible to reproduce the issue in Finder as well.

Use my test files an do like this:

In Finder copy 256K/128K/64K folder to your sharepoint on FreeNAS and you shoud see that transfer speed is about 1 MB/s and occasionally goes up to some higher rate (in my case about 15MB/s) and drops again to under 1 MB/s and so on...

But if you copy 32K folder transfer is steady all the time and about 4-5MB/s
 

Attachments

nikbok

Neophyte
Joined
Mar 16, 2019
Messages
6
Hi

I found out that my bond interface (10Gb + 10Gb) on 10.14.3 was source of issue. I've reconfigured it to single 10Gb and issue disappeared.
Everything else but SMB worked just fine on bond, strange...

I do have another problem on the same setup, when deleting my (apx. 4000) test files in Finder.
First it take a considerable amount of time and after some time or like 300-400 items deleted ends up with this error:

e1.JPG


The "32K" item is one of folders with many small files in it.
On the other hand, deleting one or few files works fine.
Worth mentioning, deleting all of 4000 files from Terminal works fine as well.
 

seanm

Senior Member
Joined
Jun 11, 2018
Messages
501
I'm also investigating performance with small files here: https://www.ixsystems.com/community...etween-single-big-file-vs-mixed-folder.74752/

Thanks for sharing your files.zip. I've downloaded it. In case it's helpful to you, on my system, copying from my 10.13.6 Mac to my FreeNAS, any of the different size folders all copy in about 25 seconds.

I've also seen Finder (on macOS 10.13.6) unable to delete folders with a lot of content. When I go inside and delete bit by bit it works. I was going to file a bug, but haven't narrowed it down yet. I've tried to repro with your dataset, but I cannot.
 
Top