install package apcupsd

Status
Not open for further replies.

bob

Cadet
Joined
Jun 28, 2011
Messages
3
Hi,

I have a (probably very basic) problem that I can not figure out how to solve. I have installed a new package, the apcupsd, to controll my UPS from Freenas. It works fine, but the problem is that it requires the configuretion file to be in /usr/local/etc/apcupsd/ (which it creates when installed). The problem is that when the box is rebooted, this directory dissapears. I have changed mode to readonly (chmod 444) on all files in this dir, have the filesystem mounted as readonly, still this directory is gone after reboot.

I can of course run a script at startup that copies everything back, but that seems like an ugly solution. Is there an other way around this?

btw: I am running 64 bit freenas from an USB stick, if that matters.

Thankyou

Bob
 

William Grzybowski

Wizard
iXsystems
Joined
May 27, 2011
Messages
1,740
/etc and /usr/local/etc which points to /etc/local are filesystems in memory, so yeah, this is the only solution...

Also, why don't you use the UPS software found in the lastest nightly builds? Doesn't that work for you?
 

catuso

Cadet
Joined
Sep 21, 2012
Messages
5
Can you Help me please Installl APCUPSD on FreeNAS v.8.2?

Can you Help me please Installl APCUPSD on FreeNAS v.8.2?

Hi,

I have a (probably very basic) problem that I can not figure out how to solve. I have installed a new package, the apcupsd, to controll my UPS from Freenas. It works fine, but the problem is that it requires the configuretion file to be in /usr/local/etc/apcupsd/ (which it creates when installed). The problem is that when the box is rebooted, this directory dissapears. I have changed mode to readonly (chmod 444) on all files in this dir, have the filesystem mounted as readonly, still this directory is gone after reboot.

I can of course run a script at startup that copies everything back, but that seems like an ugly solution. Is there an other way around this?

btw: I am running 64 bit freenas from an USB stick, if that matters.

Thankyou

Bob
 

Joshua Parker Ruehlig

Hall of Famer
Joined
Dec 5, 2011
Messages
5,949
You can put stuff in /base/conf/usr/local/etc i think which is read and copied as /usr/local/etc/ into ram upon boot.
but I suggest you just use the nut package built into FreeNAS. I got my APC ups working with it, so if you search the forums you should be able to get your UPS working with it.

I think apcupsd has some specific features nut doesn't specific for APC ups's, but nut has everything I need.
 

catuso

Cadet
Joined
Sep 21, 2012
Messages
5
I cant Find "nut package"

Hi thank you very much for your answerer. As you described I prefer to use the built in package. The thing is that I can’t find the Package in the FreeNAS drop down menu under UPS Settings.

1. Can you please tell me if it has another name or how I can find it?
2. With this package can I communicate with my Linux Server running apcupsd (Master) via LAN to initiate the shutdown?

Thank you again.

Sergio.


You can put stuff in /base/conf/usr/local/etc i think which is read and copied as /usr/local/etc/ into ram upon boot.
but I suggest you just use the nut package built into FreeNAS. I got my APC ups working with it, so if you search the forums you should be able to get your UPS working with it.

I think apcupsd has some specific features nut doesn't specific for APC ups's, but nut has everything I need.
 

Joshua Parker Ruehlig

Hall of Famer
Joined
Dec 5, 2011
Messages
5,949
Hi thank you very much for your answerer. As you described I prefer to use the built in package. The thing is that I can’t find the Package in the FreeNAS drop down menu under UPS Settings.

1. Can you please tell me if it has another name or how I can find it?
2. With this package can I communicate with my Linux Server running apcupsd (Master) via LAN to initiate the shutdown?

Thank you again.

Sergio.

The UPS settings you are looking at configure 'nut' on the backend. Not sure about the networking stuff but you might want to look into documentation for that
 
Status
Not open for further replies.
Top