Fatal trap 12: page fault while in kernel mode, 8.01 beta2

Not open for further replies.


May 31, 2011
I have been running my own SVN builds for the last 3 weeks on a NAS with 2x2TB drives in a ZFS mirror. The last build I updated to was r6767 amd64. I had my own ZFS tuning settings in loader.conf that I copied from my ZFSguru install,and my build was a 2GB one to allow me to add transmission and pyTivo. My hardware is an Intel Atom D525MW with 4GB RAM.

After a few weeks of it being stable, suddenly I've been experiencing kernel panics on FreeNAS when my iMac is performing a Time Machine backup. It runs for hours without the backup running, but crashes within minutes of it starting. The panic is a 'trap 12', and the fault code is 'supervisor write data, page not present'

I've tried deleting my config and creating it again, tried a brand new USB stick, removed all my loader.conf tweaks, and finally went back to the official FreeNAS 8.01 beta2. Absolutely nothing has worked.

Even though I ran Memtestx86 on the RAM when I built it a couple of months ago I ran it again for 5 hours (2 complete passes) and it found no errors.

The only thing I can think of is that I did update the BIOS to the latest version in an attempt to fix my CPU reporting bad (6 degrees C) temperatures via coretemp. I think I changed a couple of BIOS settings at one point but I'm pretty sure I reverted back to what I originally had.

I've attached a couple of picture of the panics from build r6767. One clearly shows afpd which was obviously being used for the Time Machine backup. Another one (not shown) happened last night on 8.01beta2 that was in one of the ZFS functions, zio_something_or_other.

I booted back into ZFSguru and imported my mirror and it seems stable again, though I only did one TM backup from another Mac, not the one that caused it 100%.

Does anyone have any suggestions as to what might be going on or how I progress from here? Perhaps my swap is bad somehow (though swapinfo correctly shows a 2G swap partition on each of ada0 and ada1)?


kpanic1.jpg kpanic2.jpg
Not open for further replies.