Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Faster Searching from Mac Spotlight or Finder of Freenas Files

TravisT

Senior Member
Joined
May 29, 2011
Messages
292
So if you can ping 172.16.110.16 from another system in your LAN and netstat -na | grep LISTEN shows port 9200 with tcp4 at *, you really should be able to connect to Elastic on that port.
That's the problem - I can't even get elasticsearch service to start if I change the network.host to anything other than 127.0.0.1. But otherwise, yes, connectivity-wise I agree with you.

netstat output:
Code:
root@crawler:~ # netstat -na | grep LISTEN
tcp4       0      0 127.0.0.1.9200         *.*                    LISTEN
tcp6       0      0 ::1.9200               *.*                    LISTEN
tcp4       0      0 127.0.0.1.9300         *.*                    LISTEN
tcp6       0      0 ::1.9300               *.*                    LISTEN
root@crawler:~ #
 

Patrick M. Hausen

Dedicated Sage
Joined
Nov 25, 2013
Messages
2,751
That's the problem - I can't even get elasticsearch service to start if I change the network.host to anything other than 127.0.0.1.
I might have overlooked it, but what happens when you set it to 0.0.0.0 or 0 which should be a valid value for "every address" according to the docs ...
 

TravisT

Senior Member
Joined
May 29, 2011
Messages
292

Patrick M. Hausen

Dedicated Sage
Joined
Nov 25, 2013
Messages
2,751
Thanks. This is something I vaguely remember having seen in production on some of our hosts at some time. All pretty vague, sorry.
So Elastic expects to be running in a clustered setup by default if there is connectivity to the outside world. You need to find out how to convince it not to do that. The error message and the Elastic docs are your best source. It's bed time for me around here, good luck :wink:

If you prefer to McGyver it:

1. Create an entry in /etc/services for 9201
2. Create an entry in inetd.conf to forward 9201 (using the service name) to 127.0.0.1 port 9200 using /usr/bin/nc (netcat)
3. Enable and start inetd
4. Use port 9201 from outside

Edit: we have some projects where we run Elastic for cool sh.. in large production environments. I have colleagues who really know this stuff. I'll ask tomorrow.
 

TravisT

Senior Member
Joined
May 29, 2011
Messages
292
Thanks. This is something I vaguely remember having seen in production on some of our hosts at some time. All pretty vague, sorry.
So Elastic expects to be running in a clustered setup by default if there is connectivity to the outside world. You need to find out how to convince it not to do that. The error message and the Elastic docs are your best source. It's bed time for me around here, good luck :wink:

If you prefer to McGyver it:

1. Create an entry in /etc/services for 9201
2. Create an entry in inetd.conf to forward 9201 (using the service name) to 127.0.0.1 port 9200 using /usr/bin/nc (netcat)
3. Enable and start inetd
4. Use port 9201 from outside

Edit: we have some projects where we run Elastic for cool sh.. in large production environments. I have colleagues who really know this stuff. I'll ask tomorrow.
Thank you! That helped tremendously. All I needed was to configure network.host to 127.0.0.1 and add this parameter to the elasticsearch.yml config:

http.host: 0.0.0.0

I can now access port 9200 remotely and locally.

Not sure that I'm out of the water yet, but this has to be forward progress.
 
Joined
Feb 10, 2015
Messages
128
Mmhh today I compiled samba by myself and enabled spotlight in the build options. The result of smbd -b | grep -I spot:
Code:
   HAVE_SPOTLIGHT_BACKEND_ES
   HAVE_SPOTLIGHT_BACKEND_TRACKER
   WITH_SPOTLIGHT

no such results on the samba version that is coming with TrueNAS-12.0-U2.1. LOL.
 
Top