SMB shares disappear from mac finder while working on files

Status
Not open for further replies.

AVSION

Contributor
Joined
Dec 28, 2016
Messages
128
Hi,

I'm new to freenas,

I have setup my new freenas sharing AFP for time machine backup and SMB for the main ZFS pool which i use it
with our imacs (main desktop computers), mac mini for kodi (as HTPC) and windows 10 laptop (work).
i setup the SMB storage datasets permission for the mac and windows and created admin user and group.
i'm able to see the shares throughout all platforms ie mac windows and can read and write.
the problem i have is only when i work on files (using mac finder) that on the storage dataset some files in the folder disappear,
or the whole storage shares disappear and i need to reconnect to the server. i also find it very slow while working on files from the server.
i have high performance server i built so i think it's something to do with my shares, storage or user setup.

if you need more information such as log report or how the Storage, shares are setup please let me know and provide detail instructions what to do.

Thank you
 

SweetAndLow

Sweet'NASty
Joined
Nov 6, 2013
Messages
6,421
Hi,

I'm new to freenas,

I have setup my new freenas sharing AFP for time machine backup and SMB for the main ZFS pool which i use it
with our imacs (main desktop computers), mac mini for kodi (as HTPC) and windows 10 laptop (work).
i setup the SMB storage datasets permission for the mac and windows and created admin user and group.
i'm able to see the shares throughout all platforms ie mac windows and can read and write.
the problem i have is only when i work on files (using mac finder) that on the storage dataset some files in the folder disappear,
or the whole storage shares disappear and i need to reconnect to the server. i also find it very slow while working on files from the server.
i have high performance server i built so i think it's something to do with my shares, storage or user setup.

if you need more information such as log report or how the Storage, shares are setup please let me know and provide detail instructions what to do.

Thank you
What version of macos? How do you connect, is it by IP or networking section?



Sent from my Nexus 5X using Tapatalk
 

AVSION

Contributor
Joined
Dec 28, 2016
Messages
128
What version of macos? How do you connect, is it by IP or networking section?

Thanks for your reply,

Here is the information below
FreeNAS 11 RC4
iMac 1 - O SX El Capitan 10.11.6
iMac 2 - macOS Sierra 10.12
usually i connect via networking section but might used IP as well, didn't test IP though.

EDIT: i tried to connect via IP in the finder i can now see two options at the same time, freenas and 192.168.1.6 and both have access to the files,
is that normal? i also deleted any freenas keychain passwords but still both showing up.
 
Last edited:

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
9,554
Thanks for your reply,

Here is the information below
FreeNAS 11 RC4
iMac 1 - O SX El Capitan 10.11.6
iMac 2 - macOS Sierra 10.12
usually i connect via networking section but might used IP as well, didn't test IP though.

EDIT: i tried to connect via IP in the finder i can now see two options at the same time, freenas and 192.168.1.6 and both have access to the files,
is that normal? i also deleted any freenas keychain passwords but still both showing up.

Seeing both of them is probably normal (not a mac user). Have you tried enabling the "fruit" VFS object on all of your Samba shares? Post the following:
- contents of /usr/local/etc/smb4.conf
- contents of /var/log/samba4/log.smbd
 

AVSION

Contributor
Joined
Dec 28, 2016
Messages
128
Seeing both of them is probably normal (not a mac user). Have you tried enabling the "fruit" VFS object on all of your Samba shares? Post the following:
- contents of /usr/local/etc/smb4.conf
- contents of /var/log/samba4/log.smbd

Thanks anodos,

No i didnt try, i just add "fruit" to the VFS objects selected box for both my storage and windows backup shares
is that how you enable fruit?

please find the files attached
 

Attachments

  • smb4.conf.txt
    2 KB · Views: 463
  • log.smbd.txt
    699.8 KB · Views: 414
Last edited:

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
9,554
Thanks anodos,

No i didnt try, i just add "fruit" to the VFS objects selected box for both my storage and windows backup shares
is that how you enable fruit?

Yes. Enable Catia as well. Under "services"->"smb" uncheck the "Hostname lookups" box. Do you still experience the problem? If so, increase logging under services -> smb, reproduce the problem, then upload a more detailed log.smbd.
 

AVSION

Contributor
Joined
Dec 28, 2016
Messages
128
Yes. Enable Catia as well. Under "services"->"smb" uncheck the "Hostname lookups" box. Do you still experience the problem? If so, increase logging under services -> smb, reproduce the problem, then upload a more detailed log.smbd.

catia enabled, hostname lookups unchecked for both smb shares. will work on it and report if problem still exist. regarding logging, if problem still exist, you mean log level increase from minimum to normal? also how is the smb4.conf looks like, is all the setting i did are correct? i.e user, groups, permission..etc and any changes in the setting you recommend?

Thanks a lot
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
9,554
catia enabled, hostname lookups unchecked for both smb shares. will work on it and report if problem still exist. regarding logging, if problem still exist, you mean log level increase from minimum to normal? also how is the smb4.conf looks like, is all the setting i did are correct? i.e user, groups, permission..etc and any changes in the setting you recommend?

Thanks a lot
I don't recall seeing anything else that needed to change. Set log level to "normal", reproduce the problem, then post /var/log/samba4/log.smbd and /var/log/samba4/log.nmbd.
 
Status
Not open for further replies.
Top