Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

AFP Time Machine share broken in FreeNAS 11.1

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.

nickt

Member
Joined
Feb 27, 2015
Messages
127
Hi all,

I'm working through a number of issues that have emerged after upgrading from FreeNAS 9.10.2 to 11.1. I've had Time Machine backups running for a few years very reliably. Since upgrading to 11.1, TM backups work occasionally, but mostly I get a "TM share can't be found" error. When this happens, I find that the AFP TM share is not browsable from my Mac (which it normally is).

There is very little I can find in logs; FreeNAS shows the AFP service running fine. Restarting the AFP service sometimes gets TM going again, but not for long.

The only possibly useful thing I have noticed in comparing start up logs between 9.10.2 and 11.1:
Code:
May 17 11:54:25 saturn netatalk[3530]: Netatalk AFP server starting
May 17 11:54:25 saturn netatalk[3530]: Registered with Zeroconf
May 17 11:54:25 saturn cnid_metad[3589]: CNID Server listening on localhost:4700
May 17 11:54:25 saturn afpd[3588]: Couldn't connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
May 17 11:54:25 saturn bridge0: Ethernet address: 02:d1:a7:3a:ff:00
May 17 11:54:25 saturn kernel: igb0: promiscuous mode enabled
May 17 11:54:25 saturn kernel: bridge0: link state changed to UP
May 17 11:54:25 saturn kernel: bridge0: link state changed to UP
May 17 11:54:28 saturn afpd[3588]: Netatalk AFP/TCP listening on 10.0.0.150:548
May 17 11:54:28 saturn afpd[3588]: No suitable network config for TCP socket
May 17 11:54:28 saturn afpd[3588]: Netatalk AFP/TCP listening on 10.0.0.150:548
All of this log activity occurs in both releases, with the exception of the "couldn't connect to system bus..." entry - this only occurs in 11.1.

I'm not too sure what to make of that error message. Would be great if anyone has any suggestions and / or has experienced problems with TM AFP shares after upgrading to FreeNAS 11.1.

Thanks,

Nick
 
Last edited:

nickt

Member
Joined
Feb 27, 2015
Messages
127
D

dlavigne

Guest
Please create a report at bugs.freenas.org and post the issue number here.
 

nickt

Member
Joined
Feb 27, 2015
Messages
127

adrianwi

Neophyte Sage
Joined
Oct 15, 2013
Messages
1,180
I upgraded a few days ago (from 9.10.1-U4) and Time Machine still appears to be running fine on all of my machines. I've had a few problems losing the AFP shares more than I did before, but nothing that restarting the service doesn't fix.

 

nickt

Member
Joined
Feb 27, 2015
Messages
127
I upgraded a few days ago (from 9.10.1-U4) and Time Machine still appears to be running fine on all of my machines. I've had a few problems losing the AFP shares more than I did before, but nothing that restarting the service doesn't fix.
Thanks for the feedback Adrian. I guess the question is: was restarting the AFP service something you had to do regularly in 9.10.1-U4? It's not something I ever had to do in 9.10.2-U6: AFP / TimeMachine was bullet proof for me. Certainly, I can restart the AFP service in 11.1 and get TM going (for a while), but that's not something I consider a long term solution.
 
Status
Not open for further replies.
Top