That message is because you aren't running in a VM. The vmware tools loads automatically on bootup with FreeNAS, but it fails to load (giving you that output) if you aren't in a VMWare VM.
You know what kills me it the fact that we are not to use FreeNAS in a VM environment yet it's built in and has been built in since day one. Gotta love it. But I do like to test the Beta's on VMWare.