Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SOLVED Upgrade to 11.2 U2 SAMBA Service will not start

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

Dave Genton

Member
Joined
Feb 27, 2014
Messages
133
Upgraded to U2 and was happy due to seeing many fixes I required but then noticed SMB service did not start. Manually starting it caused many winbindd errors stating GID exhaustion. Changing GID range didn't change the errors so I put them back to original and rebooted back to prior environment.

I did also not many sub menu area's do not open, I click on network -> interfaces, and any service and it does nothing. However if I right-click and select open a new window that menu or sub-menu opens to allow configuration. I can live with that short term but without SMB, well there's no FreeNAS to share or backup files :)
 

Dave Genton

Member
Joined
Feb 27, 2014
Messages
133
My issue isn't listed, SMB won't start. Syslog shows "winbindd cannot create group BUILTIN\Guests, GID exhausted, can winbindd create gid's ?" SMB1 is not checked, I have changed many options like adding the guest, extending gid range, etc but always same error. Changed settings back, rebooted to U1 and deleted U2 install. Today tried upgrade again, same thing, SMB won't start GID's exhausted per winbindd, cannot great BUILTIN\Guests but guest account under service still set to nobody, fails also on "guest" I created during attempts to fix.
 

Disruptor

Neophyte
Joined
Jul 6, 2017
Messages
7
Interestingly I had also an issue with the SMB shares, upgrading from 11.2 to 11.2-U2 (couldn't do U1 for the same reason). But for me my complete smb4.conf is gone, if created manually it works - but only until I stop the service, which seems to delete the .conf again. There was even an issue created for this bug during the beta of 11.2, doesn't seem to be fixed though.
 

Dave Genton

Member
Joined
Feb 27, 2014
Messages
133
I am not using LDAP as LDAP with FreeNAS to Apple's Open Directory as NEVER been fixed, or attempted to get fixed in my years of working on it anyways, but I added the posted "winbind nested groups = no" in the aux parameters of SMB and now the service starts up....
 
Top