Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

TrueNAS SCALE 22.02-RC.1 Now available!

Kris Moore

SVP of Engineering
Administrator
Moderator
iXsystems
Joined
Nov 12, 2015
Messages
904
TrueNAS Community,

We are pleased to officially announce that the first Release Candidate of TrueNAS SCALE 22.02 (Angelfish) is now available for download and upgrade! Users of the previous Beta releases are encouraged to update soon, and as always please let us know of any feedback you have along the journey.

Release Notes:


Download TrueNAS SCALE:

 
Last edited:

TooMuchData

Member
Joined
Jan 4, 2015
Messages
143
I think I followed all the links, but download button gave me TrueNAS-SCALE-21.08-BETA.2.iso.
Possibly the newsletter signup page that intervenes is wrong?
Any chance of a single link that just downloads?
 

Kris Moore

SVP of Engineering
Administrator
Moderator
iXsystems
Joined
Nov 12, 2015
Messages
904
Ahh, give it a few, web-team still updating the download page with the new files.
 

Samuel Tai

Never underestimate your own stupidity
Moderator
Joined
Apr 24, 2020
Messages
3,606

c77dk

Senior Member
Joined
Nov 27, 2019
Messages
302
painfully slow download via built-in update function (and an checksum error - aka downloading again) - but this gives time to read throgh changelog - you have been busy :D
 

TooMuchData

Member
Joined
Jan 4, 2015
Messages
143

c77dk

Senior Member
Joined
Nov 27, 2019
Messages
302
Stuck at "Import ZFS pools" :-( Back to 21.08-BETA.2

Guess it's still this bug

EDIT: it seems to be the removal of feature-flag. Has rebuild my whole system now and can boot.
 
Last edited:

Kasazn

Member
Joined
Apr 17, 2021
Messages
25
Hi, upgrading from BETA2 to this build resulted in my 2 pools being disconnected/offline.

They are not being detected.

Have to revert to Beta 2 for now. :(
 
Last edited:

Samuel Tai

Never underestimate your own stupidity
Moderator
Joined
Apr 24, 2020
Messages
3,606
@Kris Moore, there's a trickle of folks unable to import their pools from BETA2 or earlier. The known fix of destroying, recreating, and reloading the contents of the pools in question isn't tenable in many circumstances. Is there another workaround or fix? This could quickly snowball and leave a bad taste in the community's collective mouths, on top of the ongoing niggling quality issues with Core 12.0-U6. The ongoing boosterism from @JoshDW19 republishing corporate blog posts highlighting the quality of both Core and Scale is also incongruent with the community's experience. Finally, there are still unresolved issues on this forum from the CDN migration back in July, and the only word we've seen is the web admins are still working on it. What, may I ask, is going on? Has iX bitten off more than it can chew?
 
Last edited:

morganL

Captain Morgan
Administrator
Moderator
iXsystems
Joined
Mar 10, 2018
Messages
1,053
Hi, upgrading from BETA2 to this build resulted in my 2 pools being disconnected/offline. They are not being detected.
Anything unusual about the pools?.... were they created by SCALE or imported from CORE or somewhere else.
It would be good if anyone with difficulties could share their zpool features.
 

c77dk

Senior Member
Joined
Nov 27, 2019
Messages
302
Anything unusual about the pools?.... were they created by SCALE or imported from CORE or somewhere else.
It would be good if anyone with difficulties could share their zpool features.
Mine was imported from CORE. Since the importing broke in SCALE NIGHTLIES (after 21.08-BETA.1) I upgraded the featureflags in hope of something there, but nope. BETA.2 upgrade works fine, so whatever broke the import hasn't been broken there.

Native encryption enabled.
 

clausdk

Junior Member
Joined
Mar 11, 2019
Messages
14
Anything unusual about the pools?.... were they created by SCALE or imported from CORE or somewhere else.
It would be good if anyone with difficulties could share their zpool features.

I've upgraded it a few versions ago.

After the upgrade TrueNAS to "TrueNAS-SCALE-22.02-RC.1" it went offline.

This is the output of zpool import

PDfKCGk.png


So it seems its the xattr_compat?

Edit:
Well found this:

It explains everything I guess :smile:
 
Last edited:

morganL

Captain Morgan
Administrator
Moderator
iXsystems
Joined
Mar 10, 2018
Messages
1,053
It seems that the pools having import difficulty are Truenas CORE pools being used for SMB with ACLs (probably NFSv4).

If you have those, delay your updates to SCALE2 22.02-RC1 while we investigate and recommend a solution.
 

freqlabs

iXsystems
iXsystems
Joined
Jul 18, 2019
Messages
33

Indeed, the feature flag (only the flag, not the feature) had to be removed for compatibility with other systems. There is an explanation at the bottom of the RC1 release notes. In short, you'll have to recreate the pool.
 

masru

Member
Joined
Aug 9, 2020
Messages
26
It seems that the pools having import difficulty are Truenas CORE pools being used for SMB with ACLs (probably NFSv4).

If you have those, delay your updates to SCALE2 22.02-RC1 while we investigate and recommend a solution.

I have that issue with pools created in SCALE, so it's not only CORE. But I tested some ACL things while in BETA.1 ...
 

bollar

Senior Member
Joined
Oct 28, 2012
Messages
364
I have that issue with pools created in SCALE, so it's not only CORE. But I tested some ACL things while in BETA.1 ...
The release notes say that would have happened if xattr_compat=all was manually enabled in SCALE, which was possible on builds up to October 9, 2021.

Through dumb luck, this didn't impact me (my pools have xattr_compat=all disabled), but it yields a :eek::eek: from me, as I normally wouldn't have an inexpensive way to backup and recreate the pools into a system without the feature.
 

mye

Neophyte
Joined
Oct 1, 2021
Messages
10
Updating from beta2 to SCALE 22.02-RC.1. lost connection to NAS. Host is pinging but no ssh, no web UI, not responding. Will wait another 30 min, than pull a plug and see if it's booting...
Update: Can confirm. Stuck on stage Import ZFS Pools. Rolled back to Beta 2.
 
Last edited:

freqlabs

iXsystems
iXsystems
Joined
Jul 18, 2019
Messages
33
To clarify, we're not aware of any import issues related to ACLs. There is the known inability to import pools with feature@xattr_compat active mentioned in the release notes, but those systems boot normally, the affected pools simply cannot be imported. I've also seen a few issues reported where the system gets stuck forever trying to import ZFS pools at boot, but far as we're aware, none of those issues should be related to ACLs.
 

btehan

Newbie
Joined
Apr 1, 2018
Messages
1
Just to make sure here, the command "zpool get all | grep xattr" returning nothing means I'd be safe to upgrade from CORE and import my pools, right?
 
Top