Register for the iXsystems Community to get an ad-free experience

TrueNAS SCALE 22.02.1 is Now Available

eturgeon

Super Moderator
Moderator
iXsystems
Joined
Nov 29, 2021
Messages
23

bingo1105

Cadet
Joined
May 4, 2022
Messages
5
The journey from TrueNAS CORE to SCALE has been remarkably trouble free, so big thanks to the iXsystems team for all the hard work. Things are running fine after applying the .1 update to both my servers, but I have noticed UPS 'connection refused' events in syslog:

upsmon[1470509]: UPS [ups@localhost:3493]: connect failed: Connection failure: Connection refused

I checked the older logs and things appeared to be working prior to the update, so this seems like a minor regression. Just wanted to bring it to your attention...
 

morganL

Captain Morgan
Administrator
Moderator
iXsystems
Joined
Mar 10, 2018
Messages
1,681
The journey from TrueNAS CORE to SCALE has been remarkably trouble free, so big thanks to the iXsystems team for all the hard work. Things are running fine after applying the .1 update to both my servers, but I have noticed UPS 'connection refused' events in syslog:

upsmon[1470509]: UPS [ups@localhost:3493]: connect failed: Connection failure: Connection refused

I checked the older logs and things appeared to be working prior to the update, so this seems like a minor regression. Just wanted to bring it to your attention...
Please "report a bug".. does the issue survive a reboot?
 

appliance

Explorer
Joined
Nov 6, 2019
Messages
96
22.02.1 quickie:
* GOOD TO BAD (snmp): so straight away i see the fixed snmp is now stealing CPU, so this one goes disabled once again (but this time it will really turn off)
* GOOD (nfs): NFS was another component never turned on but spamming (noticed this attitude all around) - this is fixed
* BAD (middlewared): middleware still loves unicode errors:
"'utf-8' codec can't decode byte 0xb7 in position 72: invalid start byte" on sed_unlock_all despite all unlocked
* BAD (k3s): k3s rarely before, now spamming every minute with "retrying of unary invoker failed""
* BAD (k3s): busy as usual, when will this "lightweight" service calm down
* GOOD (UI): SED global setting is back to UI, no need API or CLI
* GOOD/BAD (UI): some passwords still unrevealable, but i saw bit more of them i guess.. really scary to have totally empty fields thinking the password is not there (Users)
* BAD (ups): UPS dead "nut-server start failed with code 1: 'Job for nut-server.service failed because the control process exited with error code.\nSee "systemctl status nut-server.service" and "journalctl -xe" for details.\n'"

middleware locks the poor ups service, if you wanna it, fix it on CLI:
chown nut /etc/nut/*
/etc/init.d/nut-server restart
upsc ups
battery.charge: 100

im unlocking multiple keyphrase shares on CLI each time, hope we can do this from Storage one day, as CLI mounts will disrespect mountpoint setting (/mnt/tank -> /mnt/mnt/tank), then it all gets "busy"
 

morganL

Captain Morgan
Administrator
Moderator
iXsystems
Joined
Mar 10, 2018
Messages
1,681
22.02.1 quickie:
* GOOD TO BAD (snmp): so straight away i see the fixed snmp is now stealing CPU, so this one goes disabled once again (but this time it will really turn off)
* GOOD (nfs): NFS was another component never turned on but spamming (noticed this attitude all around) - this is fixed
* BAD (middlewared): middleware still loves unicode errors:
"'utf-8' codec can't decode byte 0xb7 in position 72: invalid start byte" on sed_unlock_all despite all unlocked
* BAD (k3s): k3s rarely before, now spamming every minute with "retrying of unary invoker failed""
* BAD (k3s): busy as usual, when will this "lightweight" service calm down
* GOOD (UI): SED global setting is back to UI, no need API or CLI
* GOOD/BAD (UI): some passwords still unrevealable, but i saw bit more of them i guess.. really scary to have totally empty fields thinking the password is not there (Users)
* BAD (ups): UPS dead "nut-server start failed with code 1: 'Job for nut-server.service failed because the control process exited with error code.\nSee "systemctl status nut-server.service" and "journalctl -xe" for details.\n'"

middleware locks the poor ups service, if you wanna it, fix it on CLI:
chown nut /etc/nut/*
/etc/init.d/nut-server restart
upsc ups
battery.charge: 100

im unlocking multiple keyphrase shares on CLI each time, hope we can do this from Storage one day, as CLI mounts will disrespect mountpoint setting (/mnt/tank -> /mnt/mnt/tank), then it all gets "busy"

Thanks... that's a very useful list. We probably need to do more UPS testing in our lab.
@Kris Moore
 
Joined
Jun 2, 2019
Messages
516
* BAD (ups): UPS dead "nut-server start failed with code 1: 'Job for nut-server.service failed because the control process exited with error code.\nSee "systemctl status nut-server.service" and "journalctl -xe" for details.\n'"

middleware locks the poor ups service, if you wanna it, fix it on CLI:
chown nut /etc/nut/*
/etc/init.d/nut-server restart
upsc ups
battery.charge: 100


Even with the workarounds, UPS Slave Reporting is still blank
 

appliance

Explorer
Joined
Nov 6, 2019
Messages
96
Even with the workarounds, UPS Slave Reporting is still blank
You mean other devices didn't connect? Didn't have a chance to check.
i wanted to check post reboot UPS scenario (tho unlikely to succeed) but middleware didn't initialize because i swapped the usb flash:O It didn't mount system dataset, smb etc. Copied the root and then the flash drive died, and it's flashdrive nr.4 this month. Reason of failure must have been: those devices were simply used instead of sitting in the shelf.. Crazy how the quality deteriorated, while 10year old flashdrives still work. I'm now buying various models each week to hope to get one piece that can write without interruptions, an early indicator of longetivity.
 

bingo1105

Cadet
Joined
May 4, 2022
Messages
5
Changing ownership of the nut configuration files gets the service working again... thanks for the suggested workaround.
 

appliance

Explorer
Joined
Nov 6, 2019
Messages
96
Can't get rid of this script-breaking message by upsc:
Init SSL without certificate database
<value>
tried CERTREQUEST 0 or such in upsd.conf but doesn't help. External clients are ok. Could it be compiled with some SSL forcage?
 

appliance

Explorer
Joined
Nov 6, 2019
Messages
96
(smb) btw another cpu hogging process is smbd. Zero disk access and no activity, 2x 100% constantly. Also SMB1 devices gets "NT_STATUS_CONNECTION_RESET." after some time and freeze. Stopping Samba takes a minute.
 

appliance

Explorer
Joined
Nov 6, 2019
Messages
96
reproducing over and over:
(smb) keeps hogging cpu; shares suddenly become unavailable after some successful activity; 1min to stop; Hikvision cameras never could format their SMB1 shares; after each reboot there are only few shares published - need to open setting of any of them and save without any change to fix this
(fs) after each boot one ZRAID keeps mounting at /mnt/mnt/ no matter what and that location gets busy forever (tried to block it with a file), zfs set mountpoint doesn't work, the solution is "zpool export unluckytank; zpool import unluckytank; zfs mount -l unluckytank"
(sed) SED gets forgotten often at reboot, throws all those typical ATA errors, recreates system dataset on USB drive, and the after boot complete i type "zpool import" and it works. mislocated system dataset -> reboot -> it works.
with the snmp and ups issues on top of it, it's reasonable to not boot:)
 

morganL

Captain Morgan
Administrator
Moderator
iXsystems
Joined
Mar 10, 2018
Messages
1,681
reproducing over and over:
(smb) keeps hogging cpu; shares suddenly become unavailable after some successful activity; 1min to stop; Hikvision cameras never could format their SMB1 shares; after each reboot there are only few shares published - need to open setting of any of them and save without any change to fix this
(fs) after each boot one ZRAID keeps mounting at /mnt/mnt/ no matter what and that location gets busy forever (tried to block it with a file), zfs set mountpoint doesn't work, the solution is "zpool export unluckytank; zpool import unluckytank; zfs mount -l unluckytank"
(sed) SED gets forgotten often at reboot, throws all those typical ATA errors, recreates system dataset on USB drive, and the after boot complete i type "zpool import" and it works. mislocated system dataset -> reboot -> it works.
with the snmp and ups issues on top of it, it's reasonable to not boot:)

Sounds like your issues are quite complicated. Do you want to start a specific thread and we can narrow down which issues to report as bugs.
 

rotelly

Cadet
Joined
Apr 4, 2022
Messages
3
Looks like the group 'ladvd' gets perms to the /etc/nut directory, so not sure what else uses this group but i added the `nut` user to that group and now everything works and changes to ups.conf don't generate errors
 

georgelza

Patron
Joined
Feb 24, 2021
Messages
203
... I found https://www.truenas.com/apps/ which suppose to list all the apps available for Scale... <VERY short list>

I am only seeing Plex listed,
Unify and qbittorrent not...

So are we saying even though Unify is available as a container it is up to user himself to deploy...
anyone aware if qbittorrent as it is avail on Core is avail in container form for Scale.

G
 
Top