Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SOLVED TrueNAS-12 on Shuttle DS77u

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE


Senior Member
Apr 17, 2018
I have encountered some pitfalls when installing TrueNAS-12 on a Shuttle DS77u, so I post the solutions here.

Shuttle DS77u is a mini-pc with an Intel Kaby Lake processor, 2 Intel NICs and two harddisk slots (M2 + SATA).
This mini-pc lacks of IPMI and ECC memory but it is fan-less, so it is ideal to run jails and virtual machines without any noise.

Pitfalls and workarounds
  • By default the M2 slot is configured in SATA mode. To use a NVMe disk, enter the BIOS, switch the M2 slot to PCIe, save and exit.
  • The two Intel NIC uses different chips: Intel i211 and i219LM, so the NICs appear as igb0 and em0.
  • the Realtek RTL 8188EE 802.11 b/g/n WLAN module does not seem to work with TrueNAS-12.
  • There is only two disks slots. I use a small M2 NVMe boot disk and a large SSD SATA for the ZFS data pool. There is no disk redundancy, but I have setup a ZFS replication to backup automatically the ZFS pool. I use a pull mode because the backup server is powered on only once per week.
  • To run headless (without monitor), you have to disable the serial ports in the BIOS otherwise TrueNAS does not boot. (I have found this solution on the NetGate forum).

Finally I have a noiseless, headless mini server to run all my network services with TrueNAS-12.


Senior Member
Apr 17, 2018
Because I have neither VGA nor serial console, I have the following error message every two minutes in /var/log/messages

syslog-ng[1384]: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'

Procedure to fix this issue
Create a script to replace /dev/console by /dev/null in the syslog-ng configuration file.

# Disable logging on /dev/console
sed -i -e 's|/dev/console|/dev/null|g' /usr/local/etc/syslog-ng.conf
service syslog-ng restart

Save the script as /usr/local/bin/ and enable the execution bit
chmod +x /usr/local/bin/

Then go to the menu Tasks | Init/Shutdown scripts to run it when the computer boots
  • Description: Fix /dev/console
  • Type: Command
  • Command: /usr/local/bin/
  • When: Post Init
  • [x] Enabled
  • Timeout: 10

Reboot the server to check that the script works as expected.
Last edited: