Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Slow write performance on HDD

feyi1986

Newbie
Joined
Jan 25, 2019
Messages
3
Hi I have two 6Tb 7200RPM disks (HGST HITACH SAS 6TB HUS726060AL5211). I created a striped pool out from them. The partition alignment is set to 1MB and the ashift is set to 12. I disabled the sync and set recordsize 1M. I use this pool to store large compressed files so I also turned off the compression. Then I copy the large file (100GB) from a high speed SSD pool to this HDD pool. I get consistent write speed of 50MB/s measured by pv. I first thought the disk might be faulty. So I destroyed the pool and put these two disks in ubuntu and formated them to ext4. Then I copy the same file and I get around 160MB/s for each. Considering the data is striped in the zfs pool, I would expect getting around 320MB/s instead of only 50MB/s. I have tried different recordsize ranging from 128kb to 1MB. None of them is helping. Could anyone give some hint that I might tweak the performance?

OS:base-os-12.0-U3
CPU: 2x Intel 2650L v3
RAM: 128GB
Pool type: stripe
Ashift: 12
partition alignment: 1MB
number of disk : 2
Disk size: 6TB (each)
Disk roatation: 7200rpm
Interface: SAS
Disk write speed on ext4: ~160MB/s (each)
zfs stripe pool write speed: ~50MB/s (togather)
zfs pool compression: off
zfs xattr: sa
zfs sync: disabled
zfs record size: 1MB
 

feyi1986

Newbie
Joined
Jan 25, 2019
Messages
3
For those who experience the same problem, I solved it by issuing smartctl -s wcache,on /dev/da0 and smartctl -s wcache,on /dev/da1.
Does someone know how to enable write cache for nvme SSD on freenas?
 
Top