Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

NetBIOS browsing issue Windows 10

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.

Perrog

Neophyte
Joined
Jan 1, 2015
Messages
9
Solved: It had to do with the Windows 10 and the FreeNAS server was not on the same subnet. Next day my Windows 10 got IP in the same subnet and could connect to the file share. Similar to this thread https://forums.freenas.org/index.php?threads/cannot-resolve-netbios-name-of-freenas-machine.36363/

Edit: I cannot find this is the Windows 10 WINS/BIND problem (now adays fixed) when computer assuming the Master Browse role on network when another machine already has that role. Disabling FreeNAS Local Master does not make any difference, and I don't get error 1231 when doing "net view /all" after "net stop browser") https://social.technet.microsoft.co...res-shared-folders-in-windows-10-after-update

Has anyone else had problem finding the FreeNAS server or connecting to CIFS on Windows 10?

I'm running FreeNAS-9.3-STABLE-201602031011 FreeNAS-9.10-STABLE-201606270534. It is not frequently online since used mostly for backup.

nbtstat -n only lists my local Windows 10 desktop.
NetBIOS Local Name Table

Name Type Status
---------------------------------------------
GO <20> UNIQUE Registered
GO <00> UNIQUE Registered
WORKGROUP <00> GROUP Registered
WORKGROUP <1E> GROUP Registered
WORKGROUP <1D> UNIQUE Registered
__MSBROWSE__ <01> GROUP Registered
net view /domain only lists my WORKGROUP.

Connecting to CIFS server fails both with the IP-address and NetBIOS name. Acutally, when connecting to the IP-address first attempt displays a strange Select Certificate dialog (see attached image), but any next attempts fails with "Windows cannot access \\192.168.1.123\Backup".
I can successfully connect to CIFS server on OS X, but it uses the DNS smb://freenas.local/Backup, not the NetBIOS name.

Any hints what can be wrong? Or what to try next to get it working?
Thanks for any hints!
__________________________________
FreeNAS configuration:
Enabled "Local Master" in CIFS.

Windows configuration:
In "Network and Sharing Center" under "Change Advanced Settings":
Enabled "Turn on network discovery" for both "Private (current profile)" and "Guest or Public".

Services control panel
Set startup type Automatic for "Function Discovery Resource Publication"
 

Attachments

Last edited:

Perrog

Neophyte
Joined
Jan 1, 2015
Messages
9
Wait, I will upgrade to FreeNAS-9.10-STABLE and see if this solves the problem... thought I hade the latest stable version.
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
7,286
If you can't access your server via IP address, then it's not a netbios issue. Most likely, it's a networking issue of some sort. Post contents of /usr/local/etc/smb4.conf.
 

Perrog

Neophyte
Joined
Jan 1, 2015
Messages
9
Didn't help upgrade to 9.10-STABLE.

Here is the smb4.conf
Code:
[global]
    server max protocol = SMB2
    encrypt passwords = yes
    dns proxy = no
    strict locking = no
    oplocks = yes
    deadtime = 15
    max log size = 51200
    max open files = 470216
    logging = file
    load printers = no
    printing = bsd
    printcap name = /dev/null
    disable spoolss = yes
    getwd cache = yes
    guest account = nobody
    map to guest = Bad User
    obey pam restrictions = yes
    directory name cache size = 0
    kernel change notify = no
    panic action = /usr/local/libexec/samba/samba-backtrace
    nsupdate command = /usr/local/bin/samba-nsupdate -g
    server string = FreeNAS Server
    ea support = yes
    store dos attributes = yes
    lm announce = yes
    hostname lookups = yes
    time server = yes
    acl allow execute always = true
    dos filemode = yes
    multicast dns register = yes
    domain logons = no
    local master = yes
    idmap config *: backend = tdb
    idmap config *: range = 90000001-100000000
    server role = standalone
    netbios name = FREENAS
    workgroup = WORKGROUP
    security = user
    pid directory = /var/run/samba
    create mask = 0666
    directory mask = 0777
    client ntlmv2 auth = yes
    dos charset = CP437
    unix charset = UTF-8
    log level = 1


[Backup]
    path = /mnt/space/Backup
    comment = Windows File history
    printable = no
    veto files = /.snapshot/.windows/.mac/.zfs/
    writeable = yes
    browseable = yes
    vfs objects = zfs_space zfsacl
    hide dot files = yes
    guest ok = no
    nfs4:mode = special
    nfs4:acedup = merge
    nfs4:chown = true
    zfsacl:acesort = dontcare
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
7,286
Didn't help upgrade to 9.10-STABLE.

Here is the smb4.conf
Code:
[global]
    server max protocol = SMB2
    encrypt passwords = yes
    dns proxy = no
    strict locking = no
    oplocks = yes
    deadtime = 15
    max log size = 51200
    max open files = 470216
    logging = file
    load printers = no
    printing = bsd
    printcap name = /dev/null
    disable spoolss = yes
    getwd cache = yes
    guest account = nobody
    map to guest = Bad User
    obey pam restrictions = yes
    directory name cache size = 0
    kernel change notify = no
    panic action = /usr/local/libexec/samba/samba-backtrace
    nsupdate command = /usr/local/bin/samba-nsupdate -g
    server string = FreeNAS Server
    ea support = yes
    store dos attributes = yes
    lm announce = yes
    hostname lookups = yes
    time server = yes
    acl allow execute always = true
    dos filemode = yes
    multicast dns register = yes
    domain logons = no
    local master = yes
    idmap config *: backend = tdb
    idmap config *: range = 90000001-100000000
    server role = standalone
    netbios name = FREENAS
    workgroup = WORKGROUP
    security = user
    pid directory = /var/run/samba
    create mask = 0666
    directory mask = 0777
    client ntlmv2 auth = yes
    dos charset = CP437
    unix charset = UTF-8
    log level = 1


[Backup]
    path = /mnt/space/Backup
    comment = Windows File history
    printable = no
    veto files = /.snapshot/.windows/.mac/.zfs/
    writeable = yes
    browseable = yes
    vfs objects = zfs_space zfsacl
    hide dot files = yes
    guest ok = no
    nfs4:mode = special
    nfs4:acedup = merge
    nfs4:chown = true
    zfsacl:acesort = dontcare
Post output of the following on freenas server:
  • ifconfig
  • smbstatus
  • getfacl /mnt/space/Backup
Also try temporarily disabling the firewall and any security software on your Windows computer.
 

Perrog

Neophyte
Joined
Jan 1, 2015
Messages
9
Thanks for taking your time!
I have tried to disable Internet firewall, but it did not make any difference.

Code:
$ ifconfig
igb0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=403bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,VLAN_HWTSO>
        ether d0:50:99:5a:f8:4a
        nd6 options=9<PERFORMNUD,IFDISABLED>
        media: Ethernet autoselect
        status: no carrier
igb1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=403bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,VLAN_HWTSO>
        ether d0:50:99:5a:f8:4b
        inet 85.230.239.178 netmask 0xfffff000 broadcast 85.230.239.255
        nd6 options=9<PERFORMNUD,IFDISABLED>
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
        inet 127.0.0.1 netmask 0xff000000
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>


Code:
[root@freenas] ~# smbstatus

Samba version 4.3.6-GIT-UNKNOWN
PID     Username      Group         Machine            Protocol Version
------------------------------------------------------------------------------

Service      pid     machine       Connected at
-------------------------------------------------------

No locked files


Code:
$ getfacl /mnt/space/Backup
# file: /mnt/space/Backup
# owner: root
# group: perrog
            owner@:rwxp--aARWcCos:-------:allow
            group@:rwxp--a-R-c--s:-------:allow
         everyone@:r-x---a-R-c--s:-------:allow


I also post output from ipconfig on my Windows 10 machine.
This since I noticed Windows 10 subnet mask is 255.255.248.0, whereas my freenas netmask 0xfffff000 (255.255.240.0). Do you know if the subnet must match for CIFS and NetBIOS to work?
If I look at my OS X computer it has the subnet 255.255.240.0, i.e. same as the freenas server.
Strange that subnets can differ for computers in the same home network. I thought this was given by DHCP server, but apparently I had wrong.
Code:
Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : myisp.se
   Link-local IPv6 Address . . . . . : fe80::1133:546d:8f5c:a7%3
   IPv4 Address. . . . . . . . . . . : 85.227.149.30
   Subnet Mask . . . . . . . . . . . : 255.255.248.0
   Default Gateway . . . . . . . . . : 85.227.144.1
 

Perrog

Neophyte
Joined
Jan 1, 2015
Messages
9
Today it works! When booting my Windows 10 computer got the same subnet as the FreeNAS, and can properly connect to the CIFS file share!

Thanks for the help and all new commands I learned to run!

PS.My network consists of computers connected to a switch, which is connected to the ISP device/router. I have it this way to get full pipes to the Internet for each computer in the network. Maybe the ISP device only acts as a router for Wifi endpoints, and switch Ethernet cable endpoints. So it's randomly assigning nodes with IPs in the same subnet. DS.
PS.PS. I'm still interesting why sometimes Window's Select Certificates dialog ask me when trying to connect to CIFS. I don't have the details when and why. Is this something related to SMB protocol 3.x version? DS.DS.
Here some dumps how it looks like when it works.
Code:
$ ifconfig
igb0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
  options=403bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,VLAN_HWTSO>
  ether d0:50:99:5a:f8:4a
  nd6 options=9<PERFORMNUD,IFDISABLED>
  media: Ethernet autoselect
  status: no carrier
igb1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
  options=403bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,VLAN_HWTSO>
  ether d0:50:99:5a:f8:4b
  inet 85.227.146.137 netmask 0xfffff800 broadcast 85.227.151.255
  nd6 options=9<PERFORMNUD,IFDISABLED>
  media: Ethernet autoselect (1000baseT <full-duplex>)
  status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
  options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
  inet6 ::1 prefixlen 128
  inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
  inet 127.0.0.1 netmask 0xff000000
  nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>


Code:
[root@freenas] ~# smbstatus

Samba version 4.3.6-GIT-UNKNOWN
PID  Username  Group  Machine  Protocol Version
------------------------------------------------------------------------------
4274  perrog  perrog  customerid.myisp.se (ipv4:85.227.149.30:58045) SMB2_10

Service  pid  machine  Connected at
-------------------------------------------------------
Backup  4274  customerid.myisp.se  Sun Jul 31 21:33:55 2016

Locked files:
Pid  Uid  DenyMode  Access  R/W  Oplock  SharePath  Name  Time
--------------------------------------------------------------------------------------------------
4274  1001  DENY_NONE  0x100081  RDONLY  NONE  /mnt/space/Backup  .  Sun Jul 31 21:33:54 2016
4274  1001  DENY_NONE  0x100081  RDONLY  NONE  /mnt/space/Backup  .  Sun Jul 31 21:33:54 2016
 
Last edited:

Perrog

Neophyte
Joined
Jan 1, 2015
Messages
9
Yeah, I know this is not optimal, but I want to connect it directly to the Internet. The FreeNAS server is only turned on when needed. Can it be more secure? :)

I have some ideas to let my FreeNAS server act as a Wifi router, still being connected directly to the Internet, but only allowing CIFS and AFP inside the wifi private network. But I haven't had time/knowledge to configure this setup.
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
7,286
Yeah, I know this is not optimal, but I want to connect it directly to the Internet. The FreeNAS server is only turned on when needed. Can it be more secure? :)
I seriously doubt you want to connect it directly to the internet. You should install and configure a residential gateway / firewall appliance and configure port-forwarding rules for the services you wish to remotely access.

I have some ideas to let my FreeNAS server act as a Wifi router, still being connected directly to the Internet, but only allowing CIFS and AFP inside the wifi private network. But I haven't had time/knowledge to configure this setup.
That won't work. The solution I listed above meets these requirements and will only cost around $20.
 
Status
Not open for further replies.
Top