Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Mac Time Machine share not working after upgrade

papakpmartin

Neophyte
Joined
Feb 4, 2017
Messages
10
I just upgraded via the UI from FreeNAS latest to TrueNAS-12.0-RC1.

I have a share set up for Mac Time Machine backups that has been working OK prior to the upgrade. I'm now getting an error from Time Machine:

Time Machine couldn’t complete the backup to “freenas.local”.

The network backup disk does not support the required capabilities


Is this a known issue? What can I do to resolve this? (I've purposefully tried nothing in case there's an issue with RC1 that I can help tease out.)

"Time Machine" is checked under Sharing > SMB > Edit > Advanced Options > Other Options.
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
6,617
Okay two requests:
1) post output of following command run from CLI on MacOS: dns-sd -B _adisk._tcp.
2) post output of following command run on CLI on TrueNAS: testparm -s.
 

papakpmartin

Neophyte
Joined
Feb 4, 2017
Messages
10
Code:
~ % dns-sd -B _adisk._tcp.
Browsing for _adisk._tcp.
DATE: ---Thu 24 Sep 2020---
20:41:37.289  ...STARTING...
Timestamp     A/R    Flags  if Domain               Service Type         Instance Name
20:41:37.289  Add        2   4 local.               _adisk._tcp.         freenas


Code:
~ # testparm -s
Load smb config files from /usr/local/etc/smb4.conf
Loaded services file OK.
WARNING: some services use vfs_fruit, others don't. Mounting them in conjunction on OS X clients results in undefined behaviour.

Server role: ROLE_STANDALONE

# Global parameters
[global]
    aio max threads = 2
    bind interfaces only = Yes
    disable spoolss = Yes
    dns proxy = No
    enable web service discovery = Yes
    kernel change notify = No
    load printers = No
    logging = file
    max log size = 51200
    nsupdate command = /usr/local/bin/samba-nsupdate -g
    registry shares = Yes
    restrict anonymous = 2
    server role = standalone server
    server string = FreeNAS Server
    unix extensions = No
    idmap config *: range = 90000001-100000000
    fruit:nfs_aces = No
    idmap config * : backend = tdb
    directory name cache size = 0
    dos filemode = Yes

### ...some other shares...

[Net Backups]
    ea support = No
    kernel share modes = No
    path = /mnt/Pool1/Net Backups
    posix locking = No
    read only = No
    vfs objects = zfs_space zfsacl streams_xattr
    fruit:locking = none
    ixnas:default_user_quota = 1T
    ixnas:zfs_auto_homedir = true
    fruit:time machine = yes
    streams_xattr:store_stream_type = no
    streams_xattr:prefix = user.
    fruit:resource = file
    fruit:metadata = netatalk
    nfs4:chown = true
 

mjt5282

Member
Joined
Mar 19, 2013
Messages
123
I'm currently backing up two Mac OS X 10.15.7 / 10.15.6 laptops to a RC1 TM SMB share. It has been working fine, except in one case where the laptops couldn't find the service anymore. I stopped and restarted the SMB service and it seemed to fix it. I had some questions about the new time machine snapshots, I will post them in a separate thread.
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
6,617
Your time machine share doesn't have "fruit" set. Remove this line from your auxiliary parameters for the share.
vfs objects = zfs_space zfsacl streams_xattr
 

andrema2

Member
Joined
Aug 3, 2011
Messages
51
Your time machine share doesn't have "fruit" set. Remove this line from your auxiliary parameters for the share.
vfs objects = zfs_space zfsacl streams_xattr
Hi Anodos

My is with
Code:
vfs objects=aio_fbsd tmprotect fruit streams_xattr shadow_copy_zfs ixnas
and was working ok. From time to time I have to restart SMB service so the Macs can find the share again. Should I remove the line completely ?
 
Top