Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Issue with accessing SMB share from different workstations

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

gbrakcounty

Newbie
Joined
Nov 13, 2019
Messages
2
I am using FreeNAS-11.2-U6 on a Dell Optiplex 3010, 16GB RAM, connected/configured to our domain, 2x500GB RAID 0 as my main storage array and share. I made root the owner and applied the Share group to the root of the dataset recursively. I created a user, set a password, and made that user part of the Share group. I made the smb share to share the entire array, then once i mapped a drive in windows using the creds i created, i set explicit permissions for each folder so that only certain folders are available to domain users in our window domain. so if i log into the domain on a windows PC, i can access the share and only the two folders i specified are shown. so the weird thing is, on my windows pc that isnt on the domain, i was able to map a drive using the creds i created and was able to have full control over the whole share. if i log onto another PC as a local admin for example, regardless if the PC is or isnt on the domain, it will not accept the creds when i try to map, keeps saying network password incorrect. now it gets weirder. i have a windows pe iso that i use to image pc's. i can map a drive with the creds fine. another iso with a different windows pe image, cant map. what am i missing here?
 

gbrakcounty

Newbie
Joined
Nov 13, 2019
Messages
2
not resolve, but found a work around that is not as secure. since the freenas server is on our domain, i was able to add my domain creds to the share via windows, and now i can just use thos creds and they work every time. the thing is that im not the only one who can reset my password. not that i am worried but it is the principle of locking it down tight.
 
Top