Register for the iXsystems Community to get an ad-free experience

SOLVED Help with Install Guide: FreeNAS (FreeBSD) for nZEDb

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.

NasKar

Guru
Joined
Jan 8, 2016
Messages
733
I’m try to follow a tutorial Install Guide: FreeNAS (FreeBSD) and I’m have trouble with a section of the tutorial. I hope this is the correct place to ask if not, I would appreciate a better posting location suggestion.
nano nginx.conf # remove server segment and replace with include nzedb.conf;
nZEDb01.jpg


to this

nZEDb06.jpg


and service nginx restart gives this error

nZEDb07.jpg

any ideas on what I’m doing incorrectly?
 

danb35

Hall of Famer
Joined
Aug 16, 2011
Messages
13,548
If I had to guess (and it's only a wild guess), nano is wrapping lines and causing problems. Try deleting nzedb.conf, and creating it again, giving the -w flag to nano: 'nano -w nzedb.conf'.
 

Joshua Parker Ruehlig

Hall of Famer
Joined
Dec 5, 2011
Messages
5,946
search for the word "change" in your nzedb.conf. It somehow got inserted in there.
 

NasKar

Guru
Joined
Jan 8, 2016
Messages
733
I have setup 2 jails. 192.168.1.155 has nZEDb and 192.168.1.156 has SQL
# Change these settings to match your machine.
listen 80 default_server;
server_name localhost;
Should that be :
listen 80 http://192.168.1.155
server_name localhost;

Thanks for your help Joshua your amazing.
 

NasKar

Guru
Joined
Jan 8, 2016
Messages
733
No errors on restarting nginx so I guess that was it. When I run the ip of the jail 192.168.1.155 I get 404 not found error.
 

Joshua Parker Ruehlig

Hall of Famer
Joined
Dec 5, 2011
Messages
5,946
Is the error message from nginx?
You might want to just delete the "server_name localhost;" line so that nginx server listens on all IPs/domians.
 

NasKar

Guru
Joined
Jan 8, 2016
Messages
733
Yes the error is from nginx.
root@nZEDb:/usr/local/www # sysrc apache24_enable=YES; service apache24 start
apache24_enable: YES -> YES
apache24 does not exist in /etc/rc.d or the local startup
directories (/usr/local/etc/rc.d)

How do I fix this error?
 

Joshua Parker Ruehlig

Hall of Famer
Joined
Dec 5, 2011
Messages
5,946
Yes the error is from nginx.
root@nZEDb:/usr/local/www # sysrc apache24_enable=YES; service apache24 start
apache24_enable: YES -> YES
apache24 does not exist in /etc/rc.d or the local startup
directories (/usr/local/etc/rc.d)

How do I fix this error?
why are you doing, are you trying to use apache or nginx? if apache, I can't help I don't use it.
If nginx, then do as I said here https://forums.freenas.org/index.ph...-freenas-freebsd-for-nzedb.42465/#post-275700
 

NasKar

Guru
Joined
Jan 8, 2016
Messages
733
trying to use nginx
the instructions from the website I listed says:
Deploying the nZEDb code from GitHub:

cd /usr/local/www

git clone https://github.com/nZEDb/nZEDb.git

chown –R www:www nZEDb

Enable Apache in /etc/rc.conf and then start it

sysrc apache24_enable=YES; service apache24 start
 

Joshua Parker Ruehlig

Hall of Famer
Joined
Dec 5, 2011
Messages
5,946
Those instruction aren't perfect. ignore the apache line
 

NasKar

Guru
Joined
Jan 8, 2016
Messages
733
my rc.conf
nginx_enableportmap_enable="NO"
sshd_enable="NO"
sendmail_enable="NO"
sendmail_submit_enable="NO"
sendmail_outbound_enable="NO"
sendmail_msp_queue_enable="NO"
hostname="nZEDb"
devfs_enable="YES"
devfs_system_ruleset="devfsrules_common"
inet6_enable="YES"
ip6addrctl_enable="YES"
php_fpm_enable="YES"
apache24_enable="YES"
nginx_enable="YES"
 

Joshua Parker Ruehlig

Hall of Famer
Joined
Dec 5, 2011
Messages
5,946
my rc.conf
nginx_enableportmap_enable="NO"
sshd_enable="NO"
sendmail_enable="NO"
sendmail_submit_enable="NO"
sendmail_outbound_enable="NO"
sendmail_msp_queue_enable="NO"
hostname="nZEDb"
devfs_enable="YES"
devfs_system_ruleset="devfsrules_common"
inet6_enable="YES"
ip6addrctl_enable="YES"
php_fpm_enable="YES"
apache24_enable="YES"
nginx_enable="YES"
having the Apache line there won't hurt anything

what are you asking exactly?
 

NasKar

Guru
Joined
Jan 8, 2016
Messages
733
Do I have to change the apache24_enable="NO" ?
 

Joshua Parker Ruehlig

Hall of Famer
Joined
Dec 5, 2011
Messages
5,946

NasKar

Guru
Joined
Jan 8, 2016
Messages
733

NasKar

Guru
Joined
Jan 8, 2016
Messages
733
I did put a # in front of that line.
 

Joshua Parker Ruehlig

Hall of Famer
Joined
Dec 5, 2011
Messages
5,946

NasKar

Guru
Joined
Jan 8, 2016
Messages
733
restarted not sure how to reload
 

Joshua Parker Ruehlig

Hall of Famer
Joined
Dec 5, 2011
Messages
5,946
restarted not sure how to reload
'service nginx reload' but restart will reload from config.

Ok, if you're still getting 404 I'd enable logging in nginx then check the log file. that'll tell you what file nginx is trying to serve that isn't where it expects it.
 
Status
Not open for further replies.
Top