Not open for further replies.


Oct 3, 2018
Greetings, all. I have two FreeNAS boxes, both were running FreeNAS-11.1-U4. I did an update via the GUI and one completed successfully and is happy but the other never came back. I thought perhaps it was a malfunctioning USB drive but that doesn't appear to be it. It seems no matter what I do to fix this, I end up in grub rescue with an unknown filesystem error. I tried:
  • doing a manual update with install media (with and without formatting)
  • doing a fresh install of U6
  • doing a fresh install of U4
  • doing a fresh install of 10 (corral)
I have used both cd/dvd and usb install media and i have tried to install to different usb sticks, usb-mounted ssd drives, usb-mounted spindle drives... doesn't matter. grub rescue every time. i can't boot from sata. there doesn't seem to be a way to tell the bios to do that. i can only boot from usb or the raid controller (which is full).

i can boot to a ubuntu live cd, so there's that...

is there a way for me to repair grub? i can't seem to do anything in grub rescue because the filesystem is unknown. i can't even list the directory contents.

HP ML310 Gen8, 16GB RAM, B120i controller

thanks for any help you might be able to provide.

pro lamer

Feb 16, 2018
Is your controller on the compatible hardware list?

What are your results for ls and ls with params? (I can't find what helped me with linux but I had to start with sth like this ls ROOT@ or ls ROOT/tankname@... Guess more Google-foo around grub ls might be needed...

Ps. Have you searched our forums for "grub rescue"?

Sent from my mobile phone
Last edited:
Not open for further replies.