GRUB error after update

Not open for further replies.


Aug 8, 2016
My FreeNAS setup is running for a little more than one month now, but I ran into this issue twice with the update from 9.3 (i think) to 9.10 and 9.10.1.
When freenas bugs me about an available update and I apply it through the web console, my system won't boot afterwards and fails with the following error:

Welcome to GRUB!
error: no such device: <some 16 digit hash>
Entering rescue mode...
grub rescue>

I couldn't figure out how to repair grub in rescue mode yet. So reinstalling freenas from an usb stick is the only option. And when I install the update from said usb stick, my system boots fine. This only occurs when I trigger the update from the web console.

So my question is, why does this happen and what can i do to fix it?
I'm already afraid of keeping my system up to date, since this happened for both of the available updates I had so far and I don't like the prospect of reinstalling freenas for every update.

This is what my setup looks like:
  • Gigabyte GA-H170N-WIFI
  • Intel Pentium G4400
  • 32 GB DDR4 RAM
  • 6x 2 TB WD Red WD20EFRX
  • 2x 16 GB SanDisk Cruzer Fit Ultra USB Stick
  • Using onboard Lan and Hard Disk Controller
The HDDs are configured in a raidz2
The USB Sticks are configured as Boot Media in Raid1
I'm running a CIFS Share and a PlexMediaServer Jail


To clarify, you were trying to update to FreeNAS-9.10.1 (d989edd) and the USB sticks are mirrored?

There were some changes in the GRUB loader for this update. If the next update (in a few weeks) also gives a GRUB error, please create a bug report at and post the issue number here.


Apr 5, 2014
I also have this problem now on two FreeNAS servers which I updated today... Very good update mechanism... I will try what is suggested in this thread and see if it will work again:

Edit: Upgrading with the ISO indeed worked. I think it's not pretty that these issues arise when FreeNAS updates itself. Would updating FreeNAS with the ISO's from now on be better to not have these kind of issues?
Last edited:
Not open for further replies.