Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Completely disable TLS in Web UI

Chlorus

Neophyte
Joined
Feb 21, 2020
Messages
4
Hi folks, I've been running the qbittorrent plugin since January without issues. I have the web UI configured to serve content over HTTPS, with a certificate from my own internal CA.
Last week, I ran an update on the jail containing it to 11.3-RELEASE-p8 - as part of this, the qbittorrent version was bumped to v4.2.5. Since then, each time I browse to the Web UI over HTTPS, the connection stalls on 'Establishing secure connection' in Chrome. The web login form loads successfully if I force an HTTP connection, but on form submission it immediately redirects back to an HTTPS scheme where the connection errors out again. I've set ''WebUI\HTTPS\Enabled=false'' in qbittorrent.conf but the server still tries to redirect to HTTPS pages, probably because the server is sending a 'Upgrade-Insecure-Requests' CSP header.

How can I fully disable the HTTPS Web UI?
 

Chlorus

Neophyte
Joined
Feb 21, 2020
Messages
4
Let's see what the helpful folks in #qbittorrent on FreeNode have to say:
Code:
<xrogaan> I don't know what FreeNAS is
<xrogaan> shouldn't you ask on freenas support instead?
 

Chlorus

Neophyte
Joined
Feb 21, 2020
Messages
4
Ended up reverting the snapshot for the jail back to qbittorrent-nox 4.1.9.1 , it's working perfectly again. One thing I noticed is the newer version seems to run as qbittorrent, not as root as this older version does. I'm wondering if that messed up the pathing and now it's looking for config files in all the wrong places.
 
Top