CIFS sharing not working properly

Status
Not open for further replies.

rajsharma714

Cadet
Joined
Oct 15, 2011
Messages
3
Hello,

I installed FreeNAS (FreeNAS-8.0.2-RELEASE-amd64-Full_Install.xz) from a USB stick for the first time, and I created a ZFS volume for my 2x2TB HDD.

I followed the FreeNAS doc for CIFS Shares - "If you would like an example of how to configure access that does not require authentication, see Configuring Anonymous Access."

After all the steps were complete, clicked on FreeNAS in Windows Explorer > Network, and it is requiring me to enter a username and password.

I followed the directions in the doc exactly, so what am I doing wrong that I still need a username and password to gain access?

Any help will be great.

Thanks!
 

cbray

Explorer
Joined
Jun 16, 2011
Messages
68
Hiya,

did you check the 'Allow Empty Password' box in the CIFS settings via Services -> Control Services -> CIFS 'wrench' ?

CB
 

rajsharma714

Cadet
Joined
Oct 15, 2011
Messages
3
Hiya,

did you check the 'Allow Empty Password' box in the CIFS settings via Services -> Control Services -> CIFS 'wrench' ?

CB

Yes I did.

Attached is a screenshot of what I see when I double click of the FreeNAS > Windows (folder) from Windows Explorer > Network.

Any other ideas?
 

Attachments

  • FreeNAS.JPG
    FreeNAS.JPG
    86.5 KB · Views: 341

freshfeesh

Explorer
Joined
Oct 10, 2011
Messages
72
Chances are this is one of those things where you know you're right, but there's a setting wrong anyway. Done that plenty myself. You have to get it right on a few levels: CIFS (make sure "anonymous" authentication model, both 'allow' and 'only allow' guest checked, 'guest user' being the "guest" account that you created), at the share (right guest settings), and at the volume (use the "guest" user account you created as owner and check all rights boxes under that). It's best to not have extra users in freenas that match the names of your windows user accounts. Windows first tries to connect using the credentials of the logged in windows user. All the freenas settings you made should make that a mute point, but it wouldn't hurt to be extra conservative if you're having trouble. If you've been making a lot of tweaks, it's good to restart freenas and log off and back in to the windows user. I've heard of some freenas settings being sticky without a restart, and Windows uses cached settings to attempt login to shares that it already thinks it knows, and keeps that cache until logoff. For what it's worth, I followed those same directions and was able to access the share with full rights the first time. Good luck.
 

leenux_tux

Patron
Joined
Sep 3, 2011
Messages
238
Status
Not open for further replies.
Top