Another CyberPower UPS issue (not solved with any driver)

Underwater Mike

May 23, 2013
I have an older CyberPower CP600LCD backup for my TrueNAS Core box (TrueNAS-13.0-U6.1). The UPS is living on /dev/ugen1.3.

FreeNAS and the first releases of TrueNAS used to recognize this UPS under the usbhid-ups CPS685AVR driver. Now that doesn't seem to work. I literally tried every single CyberPower driver listed in the dropdown today, without success.

Most of the time, I see something like the following:
Feb 28 11:37:00 truenas 1 2024-02-28T14:37:00.511184-05:00 truenas.local collectd 13794 - - nut plugin: nut_connect: upscli_connect (localhost, 3493) failed: Connection failure: Connection refused
But with a couple of the drivers, I see this and nothing else:
Feb 28 11:36:40 truenas 1 2024-02-28T14:36:40.226300-05:00 truenas.local upsmon 13628 - - upsmon parent: read
Feb 28 11:36:40 truenas 1 2024-02-28T14:36:40.247355-05:00 truenas.local upsd 13620 - - mainloop: Interrupted system call

In any case, running upsc upsmon@localhost from the shell generates an "Unknown UPS" error. I also tried different USB ports but that was no help. The UPS doesn't appear in the list but, as I said, it used to work under one of the listed drivers.

I read every thread in the forums mentioning any CyberPower UPS and nothing mentioned fixed my issue. Any ideas -- either on how to get things working or why the UPS is no longer recognized? TIA