You need permission to perform this action. TrueNAS 23.10.2


Mar 10, 2024
Just installed TrueNAS 23.10.2, created several SMB Shares, one group and one user. I can connect to the shares from Windows but I cannot create folders or copy files to the share.

When I check the permissions on the Dataset, it shows the following:

Owner: root
Group: root

Unix Permissions: (this section I cannot edit)
root: Read | Write | Execute
root: Read | Execute
root: Read | Execute

I am not setting a home directory and have it set to /nonexistent and I am noticing that Home Directory Permissions are set as followings:
User: Read | Write | Execute
Group: <nothing set>
Other: <nothing set>

In all the old YT videos Group and Other have Read and Write Permissions set.

In order for me to do anything with the permissions, I must navigate to SMB shares. From here I must click on each share individually and select Edit ACL. From the Edit ACL interface, I select Group and select the *Group* I created, which has the user I created associated with it. The user has Full Permissions.

Now, I log into another PC (Windows 11) and browse to the SMB share and I am prompted to enter the SAMBA credentials, and I can see the shares. Now, I simply try to create a folder and I get the error "You need permission to perform this action." dialog box.

I am a noobie to TrueNAS and I have watched the latest videos on create Datasets, Shares on YT, but none of them are using the latest version of TrueNAS and the interface is different. I have found several posts online about this, but cannot seem to find a solution to the issue.

Can someone post a new video of creating SMB shares with 23.10.2 and connecting to them from Windows 11? Or post the exact steps of how to properly setup the shares. I am not setting a home directory set to /nonexistent and I am noticing that Home Directory Permissions are set as followings?

Any help with this is greatly appreciated.


  • Truenas-1.png
    13.6 KB · Views: 53


Mar 10, 2024
3/10 10:23PM ET Update: If I set the "Purpose" to Private SMB Datasets and Shares I can copy files, create folders from Window 11 in the share. If I create another share labeled as say photos, then if I create folder "Test1" in the photos share it shows up in all the other shares. It's as if you can only have one share set the "Private SMB Datasets and Shares".

The setup that I would like to achieve is as follows:

1. Create a Pool call BigDisks of 4x 4TB drives in RAIDZ1.
2. Create a Group called ShareUsers
3. Create a User called Test with Read | Write | Execute permissions
4. Add User called "Test" to the group ShareUsers
5. Shell = nologin
6. Samba Authentication enabled
7.Home Directory = /nonexistent
8. Primary Group = Nogroup
9. Auz Groups = ShareUsers
10. Create 3 SMB shares: Test1, Test2, Test3
11. Connect to the 3 shares from any Windows Client and be able to copy and delete files in each folder with the files being isolated in each folder.

If I follow those steps and connect from Windows 11 Client and just try to create a folder I get an error "You need permission to perform this action". It's as if the user "Test" does not have permission when it has been granted FULL permission.