Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SOLVED WOL on HP Microservers

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

Brighter

Junior Member
Joined
Nov 8, 2013
Messages
22
This probably won't be of use to most people, but for the rare few who are still using HP microservers (N54L, N40L), I thought I'd post this.

The old thread (https://www.ixsystems.com/community/threads/wake-on-lan.13508) is now locked, and the old file doesn't work for FreeNAS 11.2. Since I couldn't quite find a nice easy replacement for if_bge.ko that supported WOL, I decided to patch the existing FreeBSD 11.2 driver.

Thanks to NamTaf over at github (https://github.com/NamTaf/if_bge_wol/blob/master/README.md ) for providing the patch file.

Instructions remain the same as the original forum thread. Copy the file to /boot/kernel and add a tunable with if_bge_load with the value YES, and you're good to go.

Tested on my N54L. I'm guessing it should work for the N40L. Hope it works for you.
 

Attachments

  • if_bge.zip
    34.5 KB · Views: 465

g.maverick

Newbie
Joined
Oct 7, 2019
Messages
2
Hi Brighter, thanks for the file.

I tried to use on N36L on the latest version 11.2-U6 but I after the reboot I am having a
"This is a NAS data disk and cannot boot system” Error Message.

Are you using the same 11.2-U6 version? Or maybe it is just N36L that is not working fine with the patch.
 

Brighter

Junior Member
Joined
Nov 8, 2013
Messages
22
Hi... Can't remember which release but what you're seeing seems like your NAS is booting to your data disk instead of the OS drive. Tends to happen for me on the N54L when I swap around thumb drives or update FreeNAS.

Hope that helps...
 

g.maverick

Newbie
Joined
Oct 7, 2019
Messages
2
You are right, I have got confuse doing too many configuration at the same time.
Actually every time I was reinstall Freenas is was restoring a misconfiguration done on my first installation, I had to re-partition all the drives with g-parted to fix that.
Thanks a lot for the support.
I can confirm also on N36L & 11.2-U6 the patch enables WOL_MAGIC.
 

LVLouisCyphre

Junior Member
Joined
Dec 22, 2019
Messages
16
Actually, the HP Proliant Microserver G7 or newer I've found from reading here that it's not that uncommon of a canned FreeNAS platform. I have a pair of P54L G7s on the way that I just bought on eBay for my server garden (small server farm). I'll ping this trhread and let y'all know how it works.

I remember playing with wakie packets on the cluster of Abit BP6s (dual Celeron 533s) running FreeBSD with vintage Intel 8461 NICs with the WOL cable many moons ago. There are times when you need the granular control to power on or reboot hardware especially if you have cold standby hardware.
 

beta

Newbie
Joined
Apr 19, 2020
Messages
2
Hi Brighter,

I'm starting in the wonderful world of FreeNas.
I need the WOL (for backup Esxi VM) and I understand that this is not natively possible.

I installed 11.3-RELEASE-p7. Is this patch compatible ?

Thank you very much for you help !
Beta.
 

boydfields

Newbie
Joined
Jul 21, 2019
Messages
1
Unfortunately this solution / patch does not work on TrueNAS beta.

Any chance of an alternative or update to the driver?

Appreciate any advice.
thank you
Boyd
 

Farmer88

Newbie
Joined
Mar 17, 2021
Messages
1
Unfortunately this solution / patch does not work on TrueNAS beta. Any chance of an alternative or update to the driver? Appreciate any advice. thank you Boyd

I have compiled the driver for the actual TrueNAS-12.0-U2.1

It works for me.
 

Attachments

  • if_bge.zip
    35.6 KB · Views: 212

matthiasXh

Neophyte
Joined
May 2, 2021
Messages
4
Hello everyone,

I have compiled the driver for the actual TrueNAS-12.0-U2.1
It works for me.

I tried to apply the patch from Farmer88 on my TrueNAS-12.0-U3. After rebooting ifconfig bge0 is displaying the WOL_MAGIC term but I am not able to manage to boot the system with a WOL package.
Code:
root@freenas:~ # ifconfig bge0
bge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        description: v6
        options=c219b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MAGIC,VLAN_HWTSO,LINKSTATE>
        ether 38:ea:a7:a6:06:0a
        inet6 fe80::3aea:a7ff:fea6:60a%bge0 prefixlen 64 scopeid 0x1
        inet6 2001:470:1f0b:66e:3aea:a7ff:fea6:60a prefixlen 64 autoconf
        inet 192.168.178.50 netmask 0xffffff00 broadcast 192.168.178.255
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
        nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>


I tried it with this command on a Windows Subsystem for Linux Shell
Code:
wakeonlan -i 192.168.XXX.255 XX:YY:ZZ:AA:BB:CC

And also with the FritzBox wake on lan button and with the tool from depicus. But none of the methods worked for me, so I think i did something wrong? Do you have any hint how I can use WOL on my Freenas on a HP microserver N54L?

Thanks for your help!
Matthias
 

matthiasXh

Neophyte
Joined
May 2, 2021
Messages
4

no_connection

Senior Member
Joined
Dec 15, 2013
Messages
470
The Internet seem to be hit and miss for powerline to work. Some say flawlessly and some say plugs go to sleep with no way to wake up and some say somewhere in between.
 

matthiasXh

Neophyte
Joined
May 2, 2021
Messages
4
Ok, I will check without the powerline and direct internet connection. But for understanding why should the powerline plugs go to sleep?
I never had to restart or unplug them, they just work.
 

no_connection

Senior Member
Joined
Dec 15, 2013
Messages
470
But for understanding why should the powerline plugs go to sleep?
I assume to save power and make less noise.

I don't use those, but I can go from what ppl write and some of them do go to sleep if the computer side have not chatted in a while and won't wake up unless the computer side starts talking. The mfgrs response was there is no way to turn off that feature.
Some users report problem with multicast not working properly and so on.
I guess some adapters that only supports a single pair would be very different than those that supports many plugs etc.
 

matthiasXh

Neophyte
Joined
May 2, 2021
Messages
4
I assume to save power and make less noise.

I don't use those, but I can go from what ppl write and some of them do go to sleep if the computer side have not chatted in a while and won't wake up unless the computer side starts talking. The mfgrs response was there is no way to turn off that feature.
Some users report problem with multicast not working properly and so on.
I guess some adapters that only supports a single pair would be very different than those that supports many plugs etc.
Thank you for the help!
I changed my Powerline adapters from the TP-Link AV200+ (TL-PA251) to TP-LINK AV1300 (TL-PA8010P) and now the wake on lan does work very well. Thank you everybody for all hints and help. I don't know what the difference between these adapters is for the broadcasting or WOL packets, but now it works.
 

Nick Earle

Newbie
Joined
May 22, 2021
Messages
1
Many thanks for providing the Tunable to enable WOL for HP ProLiant G7 N40L servers, I'm using TrueNAS-12.0-U3.1
I have copied the if_bge.ko file to /boot/kernel folder and used TrueNAS GUI to add a new Tunable with if_bge_load enabled.
I'm using Wake on LAN GUI from https://wol.aquilatech.com/ and its working perfectly.
 
Top