Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Windows 10 CIFS Shares & Guest Access

Status
Not open for further replies.

engmsf

Member
Joined
May 26, 2013
Messages
41
Hi there,

I have primarily been using my Freenas 9.3 for storing files and the Plex plug-in.

Storage Dataset
/mnt/homenas/movie
Owner (user) = nobody and Owner (group) = nogroup

Sharing CIFS
/mnt/homenas/movie
Allow Guest Access = check mark

On a Windows 7 computer, to access this all I would type something like \\192.168.1.17\movie and hit enter.

On my new Windows 10, this same approach does not work, arghh! I have to enter login and password credentials. I have other shares that are login and password protected, so by entering that information can I also access my "movie". However I do not want to enter user credentials. I want the "movie" dataset to be wide open to anyone.

Any ideas? I tried enabling Guess Account Status from this thread, but it is not solving my issue.
https://forums.freenas.org/index.php?threads/windows-10-tp-cannot-connect-thru-cifs.27257/
 

FritVetBE

Member
Joined
Dec 28, 2013
Messages
87

engmsf

Member
Joined
May 26, 2013
Messages
41
Hey Frit, I have tried the following and still can't get Windows 10 to recognize a Freenas dataset for guess access automatically.

Computer Configuration --> Windows Settings --> Security Settings --> Local Policies -->Security Options --> Accounts: Guest account status = Enable
Computer Configuration --> Windows Settings --> Security Settings --> Local Policies -->Security Options --> Network acces: Let Everyone permission apply to anonymous users = Enable
Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings\Turn off password protected sharing

If I type in any dummy Freenas login and password (such as login = aa and password = bb), I can now access this movie guess dataset within Win10. I have to type in something, anything, to get the share folder mapped. Very strange. This was not needed in Win7 as described above.
 
Last edited:

FritVetBE

Member
Joined
Dec 28, 2013
Messages
87
Hey Engmsf

I was just curious and fired up a Win10 VM so I could reproduce this issue, but unfortunately I can't seem to reproduce the issue.

I'll attach my settings as how I have my CIFS service configured, together with my test dataset settings and permissions.

Is the windows 10 machine fully updated?
 

Attachments

engmsf

Member
Joined
May 26, 2013
Messages
41
Hi Frit, thanks for trying to help resolve my issue. I have uploaded the same files as well.

In your CIFS Settings, I notice you have Guess account as "guest", while mine is set to "nobody". I created a new user "guest" with auxiliary groups as nobody and nogroup. Reboot everything. Same thing happens, unable to automatically map to share folder or just simply type \\freenas\movie. I have to enter fake network credentials for login and password before I can access the files.

Windows 10 is fully updated. The problem is replicated on all 3 computers that have Win 10 installed.
 

Attachments

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
6,664
Hi Frit, thanks for trying to help resolve my issue. I have uploaded the same files as well.

In your CIFS Settings, I notice you have Guess account as "guest", while mine is set to "nobody". I created a new user "guest" with auxiliary groups as nobody and nogroup. Reboot everything. Same thing happens, unable to automatically map to share folder or just simply type \\freenas\movie. I have to enter fake network credentials for login and password before I can access the files.

Windows 10 is fully updated. The problem is replicated on all 3 computers that have Win 10 installed.
  1. Uncheck the box "disable password login" for your user "guest".
  2. Set a password for the user "guest"
  3. Change dataset so that it is owned by the user "guest" and permissions type to "windows".
  4. Under "services" -> "CIFS" change the guest user account from "nobody" to "guest"
  5. Change server max protocol to "SMB3_00"
  6. Under your share, check the boxes "allow guest access" and "only allow guest access". While you are at it, cycle the checkbox "apply default permissions".
  7. Run the command "NET USE * /DELETE" from cmd.exe on your windows client
  8. Reboot windows client
 

engmsf

Member
Joined
May 26, 2013
Messages
41
Hi anodos,

I tried your tips but still same result. See attachments where "Enter network credentials" still comes up under Windows 10. I still have to type in a fake login and password for any of my Win10 computers. Hmm I wonder if this has something more to do with Win10 than the Freenas setup.
 

Attachments

SweetAndLow

Sweet'NASty
Joined
Nov 6, 2013
Messages
6,229
I would try again after rebooting your windows box. Having the 'Allow Guest Access' and 'Only Allow Guest Access' check makes it impossible for it to ask you for a password.
 

engmsf

Member
Joined
May 26, 2013
Messages
41
I would try again after rebooting your windows box. Having the 'Allow Guest Access' and 'Only Allow Guest Access' check makes it impossible for it to ask you for a password.
Yeah I think this is strange as well. I have reboot my Freenas box several times. I have rebooted all 3 of my Windows 10 computers many more times. 2 of those are recent laptops from Dell with preloaded versions of Win 10, while the other Win10 desktop computer is an upgrade from Win7. Everything works as expected with Win7 computer, where I don't have to enter fake network credentials.
 

esamett

Senior Member
Joined
May 28, 2011
Messages
340
ping
 

mgittelman

Senior Member
Joined
Dec 8, 2017
Messages
378
Did you ever manage to fix this? Same exact situation here with windows 10, but with Freenas 11.1. Looked everywhere and tried all the advice given, but it always prompts for a username a password which will let me through if I put in some random username.
 

esamett

Senior Member
Joined
May 28, 2011
Messages
340
No. I punch in my freenas root login and it seems to work. Also periodically freenas disappears from windows network shares, typically after a windows update. There is no rhyme or reason for this. My work around is to type in \\freenas Or the IP address, setup a network share or save a link to the desktop. Sometimes the problem fixes itself after some weeks.
 

JJT211

Senior Member
Joined
Jul 4, 2014
Messages
317

marcevan

Senior Member
Joined
Dec 15, 2013
Messages
381
Umm, yes, see SMB1 is long, long, overdue for retirement. FreeNAS did as of 11.1U6 I believe (though you can add it back), Windows 10 did as of v1709 (but it's also added back), and sometime soon, it shouldn't be needed at all. SMB1 is buggy and a security concern.

Latest SMB is 3.1.1
Code:
SMB 3.1.1 was introduced with Windows 10 and Windows Server 2016.[39] This version supports AES 128 GCM encryption in addition to AES 128 CCMencryption added in SMB3, and implements pre-authentication integrity check using SHA-512 hash. SMB 3.1.1 also makes secure negotiation mandatory when connecting to clients using SMB 2.x and higher


Now SMB2 came out in 2006, so you can tell how old SMB1/CIFs is, right?
 

esamett

Senior Member
Joined
May 28, 2011
Messages
340
... required for my iphone video app
 
Status
Not open for further replies.
Top