Upgraded to 11.2

Status
Not open for further replies.

MeLLy

Dabbler
Joined
Apr 27, 2014
Messages
13
I just upgraded to 11.2 and wondered why FreeNAS didn't come back up. Once it finished the upgrade it rebooted and took forever to come back online. Sure enough, I check and it says "Can't find /boot/kernel/kernel"

Anyone else have this issue? Do I need to rebuild from scratch? What a pain in my rear!
 

MeLLy

Dabbler
Joined
Apr 27, 2014
Messages
13
I've attached a screenshot.
 

Attachments

  • freenas.jpeg
    freenas.jpeg
    145.9 KB · Views: 310

IceBoosteR

Guru
Joined
Sep 27, 2016
Messages
503
Isn't 11.2 still in BETA?
I would recommend you install latest 11.1-U5
 

sretalla

Powered by Neutrality
Moderator
Joined
Jan 1, 2016
Messages
9,703
You can try an install USB and install over the top of the existing installation to "repair" it (assuming it's not a disk error causing the problem). That should be non-destructive to what you have on the install already.

I agree with @IceBoosteR that you probably don't want a Beta version if this kind of experience is troubling for you.
 

MeLLy

Dabbler
Joined
Apr 27, 2014
Messages
13
Troubling me? I know I can reinstall but I am reporting an issue. Am I not supposed to come to the forums to report info such as this? And by the way, the branch did say 11.2-STABLE.
 

IceBoosteR

Guru
Joined
Sep 27, 2016
Messages
503
Troubling me? I know I can reinstall but I am reporting an issue. Am I not supposed to come to the forums to report info such as this? And by the way, the branch did say 11.2-STABLE.
I have double checked this. It is still BETA.
Try 11.1 instead, see if the eror persists. If not, be happy and upgrade later.
If you submit a bug - awesome. The devs can fix it. But it wont be in the near future. OF course you can share your experience, but the developers often don't have a look into the forums, more on the bugtracker.
 

MeLLy

Dabbler
Joined
Apr 27, 2014
Messages
13
Yeah I'm going back to 11.1. I'll report it to bugtracker. I didn't realize they don't pay much attention in here. Thanks!

Just a note, if the branch isn't stable it shouldn't say it is! It should say 11.2-BETA or 11.2-ALPHA. That is very confusing.
 

IceBoosteR

Guru
Joined
Sep 27, 2016
Messages
503
Yeah I'm going back to 11.1. I'll report it to bugtracker. I didn't realize they don't pay much attention in here. Thanks!

Just a note, if the branch isn't stable it shouldn't say it is! It should say 11.2-BETA or 11.2-ALPHA. That is very confusing.
Thanks.

Yes I do agree. They should change the name from stable to beta....
 

Brer

Explorer
Joined
Mar 2, 2017
Messages
63
I just upgraded to 11.2 and wondered why FreeNAS didn't come back up. Once it finished the upgrade it rebooted and took forever to come back online. Sure enough, I check and it says "Can't find /boot/kernel/kernel"

Anyone else have this issue? Do I need to rebuild from scratch? What a pain in my rear!

I'm having the same issue, I haven't found a way around it yet, U5 installs flawlessly. This is the first update/fresh install I've had problems with. I posted here :-

https://forums.freenas.org/index.php?threads/11-2-beta1-upgrade-and-fresh-install.68487/
 

xcom

Contributor
Joined
Mar 14, 2014
Messages
125
Yeah I'm going back to 11.1. I'll report it to bugtracker. I didn't realize they don't pay much attention in here. Thanks!

Just a note, if the branch isn't stable it shouldn't say it is! It should say 11.2-BETA or 11.2-ALPHA. That is very confusing.

This!!!! I have been there before so please ix, Listen to this post :D
 

Astrodonkey

Explorer
Joined
Jul 18, 2017
Messages
72
I moved to 11.2-Beta 1 and "uname -a" is puzzling to me as it still indicates 11.1.

Code:
root@freenas:~ # uname -a
FreeBSD freenas.local 11.1-STABLE FreeBSD 11.1-STABLE #0 r325575+b31fa24ea5b(freenas/11-stable): Thu Jul  5 16:57:13 EDT 2018 
root@nemesis.tn.ixsystems.com:/freenas-11.2-releng/freenas/_BE/objs/freenas-11.2-releng/freenas/_BE/os/sys/FreeNAS.amd64  amd64
 
Status
Not open for further replies.
Top