Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Unable to install - pkg error: - qbittorrent-nox :,lang/python3

Jailer

Not strong, but bad
Joined
Sep 12, 2014
Messages
4,434
It's displayed in the terminal the last time I updated.
 

davev

Neophyte
Joined
Oct 9, 2020
Messages
4
Just upgraded to U5 and still getting the same issue
Error: Torrent had a failure Exception: RuntimeError Message: pkg error: - qbittorrent-nox : Refusing to fetch artifact and run post_install.sh! Partial plugin destroyed
 

Zzyzx

Newbie
Joined
Apr 16, 2020
Messages
3
Just upgraded to U5 and still getting the same issue
Error: Torrent had a failure Exception: RuntimeError Message: pkg error: - qbittorrent-nox : Refusing to fetch artifact and run post_install.sh! Partial plugin destroyed
Looks like qbittorrent-nox has been dropped from both latest and quarterly for FreeBSD:11:amd64: https://www.freshports.org/net-p2p/qbittorrent/
 

Jailer

Not strong, but bad
Joined
Sep 12, 2014
Messages
4,434
Looks like if users don't already have it installed they will have to wait for TureNAS 12 to come out so they can run it on a FreeBSD 12 jail. Bummer.
 

Jailer

Not strong, but bad
Joined
Sep 12, 2014
Messages
4,434
Had it installed on U4 and it stopped working after upgrading to U5
Strange, mine is working fine on U5 but then again I'm not running the plugin, it's a manual install.
 

davev

Neophyte
Joined
Oct 9, 2020
Messages
4
Can you pint me to instruction for manual install. One I found so far does not work.
 

HPloco

Neophyte
Joined
Oct 25, 2018
Messages
4
The PKG was removed from the repo for FreeBSD 11. Unless someone can compile a pkg from scratch or someone saved the original you wont be able to install it. And even then with qt5 having incompatibility issues you might run into other bigger roadblocks,
 

gunnahafta

Neophyte
Joined
Nov 5, 2018
Messages
10
So sounds like if you don't already have qbittorrent up and running as either plugin or jail your ****ed. Am i right?
 

Jailer

Not strong, but bad
Joined
Sep 12, 2014
Messages
4,434
So sounds like if you don't already have qbittorrent up and running as either plugin or jail your ****ed. Am i right?
If you are on FreeNAS 11.3 or older yes. If you're willing to update to TrueNAS core 12 then you can create a jail or plugin and install it.
 

gunnahafta

Neophyte
Joined
Nov 5, 2018
Messages
10
Yep I was thinking that. Took the plunge. Upgrade was so painless. Everything came up. Kudos to the team for an easy upgrade process.

Now to get that Jail working.
 
Top