Unable to boot from Installer USB


Jun 28, 2019
I am currently having issues booting from an Installer USB created in Linux using the "dd" command as was written in the documentation. The copy operation of the .iso file appears to have been successful, as my Linux machine outputs the following:


While this does work, I am unable to boot from the install flash drive in order to install FreeNAS. I have tried modifying the BIOS order to boot from removable drives first (and even disabled hard drive boot at one point). However, attempting to boot from the flash drive either results in the computer not recognizing it as a boot device and thus booting from the hard drive instead, or it results in a boot loop where various BIOS screens pop up and then the computer restarts, being unable to boot. Opening up the boot menu only gives me the option to boot to the normal OS, rather than allowing me to select the flash drive as an option to boot from.

I also tried removing the hard drive entirely, which resulted in a blank console flashing. This console failed to do anything after 40 minutes although I noticed the flash drive with the installer getting particularly warm. I'm not sure if this was the intended behaviour and that the .iso file takes a long time to decompress and boot, or if this was too long. Other attempts with the hard drive taken out resulted in an "INSERT SYSTEM DISK THEN PRESS ENTER" message. Inserting the flash drive at that point, then pressing enter, did not succeed.

How can I make the installer work on my machine? Nothing in the BIOS seems to help with the installation. I have tried creating the installer flash drive on Windows as well and my computer is still unable to boot from the drive. I'm unclear whether this is a localized issue with the machine or whether I'm just plain stupid and can't figure out how to boot from the flash drive.

System Specs:

Motherboard: NVIDIA SLI nForce, unclear which model exactly (I think 790i). The BIOS is a PhoenixBios D686 BIOS.
CPU: Intel© Core™ i7 CPU X 980 @ 3.33GHz × 6
RAM: 12 GB of Corsair XMS3 Platinum Series RAM (in the form of 2 6GB sets).
Hard drives: Only one at the moment. It is a Samsung 850 EVO SSD, with a storage capacity of 250GB. The model number is MZ-75E250. It also happens to be the boot drive and is not in a RAID setup.
Hard disk controllers and network cards: unknown. I can probably dig into the computer's innards to find it if necessary.