Truenas Scale - The web interface cannot be accessed (IP issues)

jaipee12

Cadet
Joined
Mar 15, 2024
Messages
1
Hi, I am quite new to networking, however I have been doing my own research on this issue for weeks now and cannot get my NAS device to work correctly.

Originally I bought a Terramaster f4-423 and installed Truenas scale as my OS (instead of using terramaster's OS). Everything went well and i set up a SMB so I could it use it for PLEX. It was working well for months. However, it seems as though the assigned IP (DHCP, i did not assign a static IP), has changed. The original IP is now being used by another device in my home network. It is strange because I have not turned off the device or changed routers, it just stopped working (maybe a storm had affected it?)

When i connect the NAS to a monitor i get the message "the web interface could not be accessed". I used the command ifconfig (pic attached) to find the MAC address of the NAS Server so I could see which IP address it has been assigned. For some reason there are two mac addresses, one under enp1s0 and one under enp2s0 (pic atatched). I assume that the second is used as a bridge for use with PLEX? However, after scanning using advanced IP scanner, i cannot see a device on the network at all which matches either MAC address.

Maybe it was assigned an IP which was outside of the scanning range? Regardless, I want to find a way that I can allocate the original IP address back to the NAS server (because I assume it ties with everything I have set up to get plex working). I followed this tutorial to set up plex with truenas scale https://www.youtube.com/watch?v=3GpaxFYe3MU&t=73s

I have tried connecting the NAS server directly to my PC via ethernet and rescanning using advanced IP Scanner and it still does not show up. I have also tried scannig using wireshark while connected and it also comes back with nothing.

I apologise if this is a simple fix, however I am all out of ideas and i cannot use (or log into via internet browser) my NAS rendering it unusable at the moment. Any help will be greatly appreciated.
 

Attachments

  • Screenshot 2024-03-16 170206.png
    Screenshot 2024-03-16 170206.png
    1.6 MB · Views: 61
  • Screenshot 2024-03-16 170227.png
    Screenshot 2024-03-16 170227.png
    214.1 KB · Views: 61
  • Screenshot 2024-03-16 170329.png
    Screenshot 2024-03-16 170329.png
    1.2 MB · Views: 59

chuck32

Guru
Joined
Jan 14, 2023
Messages
623
Are you using ipv6 internally? Don't see an ipv4 here. Not bad, just an observation.

Edit one network interface and assign a static IP that is free. Make sure thats the one you attached your cable to.

This will give you access for now.

Take the device that is now using your desired IP offline (or release the IP by other means) and try to change the IP to that in your truenas GUI. It will allow you to test the setting before making it permanently.

You could skip the step of using another free IP first but I assume it will be easier to troubleshoot from the GUI for you.

A network bridge will show up as brX and then a number. I guess you just have two Ethernet ports on your server.
 

danb35

Hall of Famer
Joined
Aug 16, 2011
Messages
15,504
For some reason there are two mac addresses, one under enp1s0 and one under enp2s0 (pic atatched).
You have two physical interfaces, which will naturally have separate MAC addresses. Neither of those is a bridge, and I have no idea why you'd assume this to be the case.

As Chuck said, edit one interface (I'd suggest enp2s0, since that appears to be the one that's plugged in) to have a static IP address and go from there.
 
Top