TrueNAS Scale 23.10.2 Cannot Boot on Dell Optiplex 790DT


Mar 4, 2024
I am installing TrueNAS Scale for the first time on a Dell Optiplex 790DT (see spoiler tag for details). I installed without EFI so it would legacy boot. When I arrive at the one time boot screen, TrueNAS-0 is listed under the UEFI section. If I select it with Enter, the screen goes blank and nothing happens. If I then use the arrow keys up and down, it reveals the options again and I'm back to where I was.

I noticed that I had the A16 BIOS installed, so the first thing I tried was updating to the latest A22 BIOS version. I created a bootable FreeDOS USB with Rufus and copied the latest BIOS version to it. I then booted from the USB and ran:
> dir
> O790-A22.exe

Where the first character is the letter O despite it displaying as zero by FreeDOS. The BIOS installed successfully.

However, it still would not boot.

I then tried checking and unchecking TrueNAS under the UEFI section in the BIOS settings without success. Finally, I tried reinstalling TrueNAS with EFI and flicking the UEFI setting but again, no success.

I have been reluctant to believe that having an M.2 drive with an adapter in the PCIe slot is the cause because I was able to install TrueNAS on that drive in the first place and it has been detected by the BIOS. Is there anything else I can try?

System Details List
Dell Optiplex 790DT
A22 BIOS (Up to date)

Patriot P300 M.2 PCIe Gen 3 128GB NVMe SSD installed in PCIe adapter
i5-2500 CPU @ 3.3GHz, 4-core, 64-bit