Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Truenas and Samba permissions

trek102

Member
Joined
May 4, 2014
Messages
33
I have several Samba shares all with Truenas default settings (ACL everyone allowed full) but on my Linux client (Ubuntu 20.04) I cannot write even if they show mounted as 'rw'.
What am I doing wrong in the Truenas settings?
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
7,203
I have several Samba shares all with Truenas default settings (ACL everyone allowed full) but on my Linux client (Ubuntu 20.04) I cannot write even if they show mounted as 'rw'.
What am I doing wrong in the Truenas settings?
Let's start with two things:
1) post output of "testparm -s" so that we can see how the server is configured.
2) post exact mount parameters used on Linux client.
3) increase SMB log level to "FULL" and then send me a copy of /var/log/samba4/log.smbd after a failed write attempt.
 

trek102

Member
Joined
May 4, 2014
Messages
33
Code:
[global]
    aio max threads = 2
    bind interfaces only = Yes
    disable spoolss = Yes
    dns proxy = No
    enable web service discovery = Yes
    kernel change notify = No
    load printers = No
    logging = file
    max log size = 5120
    nsupdate command = /usr/local/bin/samba-nsupdate -g
    registry shares = Yes
    restrict anonymous = 2
    server min protocol = NT1
    server role = standalone server
    server string = TrueNAS Server
    username map = /usr/local/etc/smbusername.map
    username map cache time = 60
    idmap config *: range = 90000001-100000000
    fruit:nfs_aces = No
    idmap config * : backend = tdb
    directory name cache size = 0
    dos filemode = Yes


[trueshare1]
    ea support = No
    kernel share modes = No
    path = /mnt/zpool1/data1
    posix locking = No
    read only = No
    vfs objects = fruit streams_xattr shadow_copy_zfs ixnas aio_fbsd
    fruit:resource = stream
    fruit:metadata = stream
    nfs4:chown = true


[data1mirror]
    ea support = No
    kernel share modes = No
    path = /mnt/zpMirror/data1mirror
    posix locking = No
    read only = No
    vfs objects = fruit streams_xattr shadow_copy_zfs ixnas aio_fbsd
    fruit:resource = stream
    fruit:metadata = stream
    nfs4:chown = true
 

trek102

Member
Joined
May 4, 2014
Messages
33
2) mount command
sudo mount.cifs //192.168.1.137/trueshare1 ~/mnt/true1 -o user=nmax
 

trek102

Member
Joined
May 4, 2014
Messages
33
Thanks - Attached is my Service-SMB screen -> sorry, cannot see log level.
Please find below getfacl output:

getfacl /mnt/zpool1/data1
# file: /mnt/zpool1/data1
# owner: nmax
# group: wheel
owner@:rwxp--aARWcCos:-------:allow
group@:rwxp--a-R-c--s:-------:allow
everyone@:rwxp--a-R-c--s:-------:allow
truenas% getfacl /mnt/zpool1
# file: /mnt/zpool1
# owner: root
# group: wheel
owner@:rwxp--aARWcCos:-------:allow
group@:r-x---a-R-c--s:-------:allow
everyone@:r-x---a-R-c--s:-------:allow
 

Attachments

Top