Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SSH FreeNAS to Mac - please help

Status
Not open for further replies.

gabsd

Junior Member
Joined
Feb 11, 2014
Messages
24
I have a FreeNAS box for home use - the usual pictures, movies, music, etc. I have very little knowledge or experience with networks, but with a lot of courage and reading, I've been able to create a backup of everything on that FreeNAS over localhost, to a disk that I swap and store off-site.

Now, I also want to use an old Mac mini to create an extra backup to an external disk that, if I am not around, anybody in my family could plug into any computer and read - in other words I want a backup in exFAT. So after extensive searching I think the solution would be rsync.

Here's what I have going so far:

PUSH: FreeNAS 9.3 at 10.0.0.22
PULL: Mac mini running Lion at 10.0.0.24
data to backup: /mnt/orange
target: external drive mounted as /Volumes/BK2 in the Mac mini

I created a key pair on PUSH as instructed in FreeNAS user guide:

ssh-keygen -t rsa

Next I got the contents of the public key by:

more .ssh/id_rsa.pub

In PULL, I enabled remote log in to turn on SHH daemon in the Mac mini. I generated a key pair with the same command as above. I appended the public key I had copied from FreeNAS into /var/root/.ssh/id_rsa

Next I copied the host key of PULL using the shell on PUSH, again as instructed in the FreeNAS manual:

ssh-keyscan -t rsa 10.0.0.24 >> /root/.ssh/known_hosts

Finally I created an rsync task on PUSH:
path: /mnt/orange
remote host: 10.0.0.24
remote path: /Volumes/BK2
Rsync mode: Rsync over SSH
user: root
group: wheel

and ... it doesn't work. The problem seems to be the remote path. FreeNAS says the path doesn't exist or it is not a folder. I tried everything I could think of, nothing worked:
/Volumes/BK2
/Volumes/BK2/
/Volumes/BK2/Folder
/Volumes/BK2/Folder/

If I use the FreeNAS shell to SSH to the Mac mini, it lets me connect, and I can navigate to /Volumes/BK2, so the SSH is working, but still no Rsync. I should say that when I SSH from the shell, it asks me for the root password in the Mac mini - not sure that matters.

What is the very stupid basic thing I am missing?
 
Last edited:

wblock

Documentation Engineer
Joined
Nov 14, 2014
Messages
1,505
In your original post (now edited), every instance of "SSH" was spelled "SHH". So the first thing to check is that none of those misspellings made it into file or directory names.
 

fracai

Neophyte Sage
Joined
Aug 22, 2012
Messages
1,210
In PULL, I enabled remote log in to turn on SHH daemon in the Mac mini. I generated a key pair with the same command as above. I appended the public key I had copied from FreeNAS into /var/root/.ssh/id_rsa

Next I copied the host key of PULL using the shell on PUSH, again as instructed in the FreeNAS manual:

ssh-keyscan -t rsa 10.0.0.24 >> /root/.ssh/known_hosts
known_hosts is a cache of systems you've connected to before. If that system key changes, you'll be notified in case someone is impersonating the system.
You instead want your public key appended to "authorized_keys"

**edit: I originally wrote "authorized_hosts" instead of "authorized_keys"
 
Status
Not open for further replies.
Top