SMB issues


May 7, 2023
I had 3 shares with 1 user (named bob), and everything was going smoothly with SMB access using OSX. Then I wanted to add 2 more users, so each share was owned by 1 user, and each user could not access any of the other shares except their own. This is where everything fell apart. After editing each share's filesystem acl user and group, it was still only letting me smb connect using bob, and none of the other accounts worked. On the non-bob shares, I tried a few different ACL presets with the same results, tried applying the permissions recursively, then later checked the box for child datasets. Realizing I screwed things up, I strip'd the acls, and checked the box for removing permissions from child datasets. With all this I was still able to smb connect to bob's share. After several days of giving up and only using bob's share, it wouldn't let me smb connect anymore. I did the same process, stripping acl's, removing shares and recreating them, and I still can not connect. I even removed all shares and all users (except root), and recreated user bob (with smb auth checked ) and the smb share and an open acl, but it won't connect. How badly have I messed things up and how do I fix this?


Jan 14, 2023
Please share screenshots of your configuration.

What I would do,

1) Strip all ACL recursively and for all child datasets.
2) Add new ACL preset (open or restricted, whatever you like)
3) Add your user and apply permissions recursively
4) No MacOS experience here, unmap the shares
5) Remove smb credentials from MacOS (in Windows that has helped me a ton before)
6) Add the shares in MacOS and authenticate again

this should give you a fresh start where nothing is messed up.

it is crucial though that you share your configuration in order to rule out that you made conflicting changes during your attempt of resolving this issue.