SMB and/or dataset user access controls not working correctly after restore config from backup


Sep 15, 2014
I had a boot drive failure on 13.0-U6 so I reinstalled on 13.0-U6.1 and restored the config from backup. Everything restored successfully (users, groups, non-encrypted pools, encrypted pools, SMB shares, CAs, certs, replication tasks, cron jobs, and a plugin). But I am having a problem with user access when logging into SMB shares.

I have a user uid=1000 who is member of many groups and can access most datasets. When he logs in as a SMB user he only has read access to a couple of shares that everyone is allowed to read, and has access to no other shares. This is the same for 3 other users when they login as SMB users on both Windows and Linux. This all worked perfectly before the boot drive failure.

I have tried:
  • Reset the user's password on TrueNAS
  • Reset the login credentials from the Windows client (via the Windows Credential Manager)
  • Verified the dataset ACLs on one of the shared datasets that couldn't be accessed and reconfigured user and group ownership with recursive selected
  • Verified that the SMB share ACLs are correct (Everyone, Full, Allowed)
  • Creatied a test dataset and matching SMB share with a test user as owner. Even this isn't working: the test user logged in as a SMB user cannot access this share at all.
Any help would be greatly appreciated.

EDIT: Clarifications.
Last edited: