shutdown -r of bhyve guest leaves VM in "STOPPED" state

Status
Not open for further replies.

Patrick M. Hausen

Hall of Famer
Joined
Nov 25, 2013
Messages
7,776
FreeBSD (or Linux, doesn't matter) UEFI boot VM in bhyve/FreeNAS 11. shutdown -r now in guest. Clean shutdown, but instead of coming up again the machine is left in the "STOPPED" state.

Bug or feature?

Thanks,
Patrick
 
D

dlavigne

Guest
Do you get the same issue if you use the VM's restart button?
 

Patrick M. Hausen

Hall of Famer
Joined
Nov 25, 2013
Messages
7,776
I rarely use Stop or Restart from the UI, because that causes an unclean shutdown of the VM. And to answer your question: yes.

I just tried it to verify, then booted single user for the necessary fsck, then tried this:
Code:
# reboot
Nov 28 20:20:39 init: single user shell terminated.
Waiting (max 60 seconds) for system process `vnlru' to stop...done
Waiting (max 60 seconds) for system process `bufdaemon' to stop...done
Waiting (max 60 seconds) for system process `syncer' to stop...
Syncing disks, vnodes remaining...0 0 0 0 0 0 0 0 0 done
All buffers synced.
Uptime: 29s

That's it. No more console output, machine "STOPPED" in the UI.

The machine has got the two devices, who's config I attached. I don't need VGA/VNC for machines running FreeBSD or Linux. The guest OS is RELENG_10_4, but machines with RELENG_11_1 or Ubuntu behave exactly the same way.

Patrick
 

Attachments

  • device-disk.png
    device-disk.png
    46.1 KB · Views: 223
  • device-nic.png
    device-nic.png
    53.3 KB · Views: 225
  • settings-vm.png
    settings-vm.png
    69 KB · Views: 224
Last edited:
D

dlavigne

Guest
In that case, please create a bug report at bugs.freenas.org and post the issue number here.
 

Patrick M. Hausen

Hall of Famer
Joined
Nov 25, 2013
Messages
7,776
Status
Not open for further replies.
Top