Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Poor performance for AFP/CIFS Share on Mac OS 10.9 Mavericks

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.
Joined
Aug 13, 2013
Messages
96
Well, that actually depends what version of Mac OS X you are running. Because Apple has "optimized" different things on different version of their OS. I know that article, but would also like to say that its focused on getting the best performance on the WAN connection. (high latency connections)
But what we are looking for is high performance in low latency environments like in 10GbE.

The best settings I have found is actually comming from a guy on creativecow forum. I have adjusted it a bit. But again all these settings depends on so many variables that you can't find the "holy grail".
This works okey in Yosemite and has only been partially tested in El Capitan.

Lines for /etc/sysctl.conf
Code:
net.inet.tcp.doautorcvbuf=0
net.inet.tcp.doautosndbuf=0
net.inet.tcp.sendspace=4194304
net.inet.tcp.recvspace=4194304
net.inet.tcp.maxseg_unacked=32
net.inet.tcp.delayed_ack=2
net.inet.tcp.win_scale_factor=7
net.inet.tcp.rfc1323=1


disclaimer: Always make a backup of the file your are changing. Use your head. Test settings by only testing one setting at a time. Its tedious work to find the best setting.
 

helloha

Member
Joined
Jul 6, 2014
Messages
109
Well, that actually depends what version of Mac OS X you are running. Because Apple has "optimized" different things on different version of their OS. I know that article, but would also like to say that its focused on getting the best performance on the WAN connection. (high latency connections)
But what we are looking for is high performance in low latency environments like in 10GbE.

The best settings I have found is actually comming from a guy on creativecow forum. I have adjusted it a bit. But again all these settings depends on so many variables that you can't find the "holy grail".
This works okey in Yosemite and has only been partially tested in El Capitan.

Lines for /etc/sysctl.conf
Code:
net.inet.tcp.doautorcvbuf=0
net.inet.tcp.doautosndbuf=0
net.inet.tcp.sendspace=4194304
net.inet.tcp.recvspace=4194304
net.inet.tcp.maxseg_unacked=32
net.inet.tcp.delayed_ack=2
net.inet.tcp.win_scale_factor=7
net.inet.tcp.rfc1323=1


disclaimer: Always make a backup of the file your are changing. Use your head. Test settings by only testing one setting at a time. Its tedious work to find the best setting.


Thank you very much, I'm still on 10.9 because of device support. I'll try a few things and report my findings.

Cheers!
Karel.
 
Status
Not open for further replies.
Top