Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Pool DuffleBag state is DEGRADED :(

Ruff.Hi

Member
Joined
Apr 21, 2015
Messages
248
Don't you hate getting an alert email with status ALERT

I do. My pool is degraded with the message 'Disk 5236302700148676277 is FAULTED'

Useful ... I checked the zpool status and a disk reported read and write delays. Lots of them. I swapped out the drive, cleared the zpool and reslivered. Only to have the alert raised again ... same location, different drive.

What had changed recently? I had added an HBA ... this one ... https://www.amazon.com/dp/B00DSURZYS ... and I was running some of my HDDs from one of its 'ports'. I turned off the server, moved back to the motherboard port and replaced the HDD (in-place). Currently reslivering.

It is not one of the HDDs. The same error in the same location either says (to me) either stat cable or HBA. I don't think it is the cable - I am using 2 x CableCreation Internal HD Mini SAS (SFF-8643 Host) and have been for a while (both off the mother board).

How do I test the HBA to see if this is the culprit?
 

jgreco

Resident Grinch
Moderator
Joined
May 29, 2011
Messages
13,716
Make sure that you have airflow over the HBA.

The HBA is a server component that is designed for environments where airflow is guaranteed. It dissipates 10-15W, because it is a small PowerPC computer in its own right, and a common mistake is to assume that it is just a trite add-on card. They can actually take a good bit of abuse, but there is such a thing as "too far", and when I see 120mm fans and the words "swapped out", I get a bit concerned.
 

Ruff.Hi

Member
Joined
Apr 21, 2015
Messages
248
Thanks for the post.

I had to had a graphic card (onboard vga connection failed) and I moved the GPU down one so that HBA has 'space'. The Typhoons are good radiator fans as it is sucking air through the HDD cages. That said, the Anidees has plenty of room to add air flow fans so I can do that if required. Is there a way of monitoring the HBA temp? I will do some googling and see what I can find.
 

Ruff.Hi

Member
Joined
Apr 21, 2015
Messages
248
Oh ... slow HDD slot again ... even after swapping cable back to motherboard. Pulled the HDD cage and detached / reattached the sata cables. It might not be the HBA. It might be me :(
 

Ruff.Hi

Member
Joined
Apr 21, 2015
Messages
248
Nothing from that drive since I reattached the sata cables. So, human error for the bad read / writes.

I have a pci-e riser fan attachment thingo coming ... I will install that before I start pushing on the HBA.
 
Top