Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Please help. Share SMB not seeing by MAG256 media player 11.1U6

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

tiberiu

Neophyte
Joined
Dec 24, 2016
Messages
7
Hello. I upgrade to 11.1U6 and I lost the share I used to see in media player MAG256 box.
Before the upgrade I used 11.1U4 and it worked no problem. If I downgrade It will work again. I like to use the latest version of freenas 11.2 but that one also it give me the same problem.
I can see the share folder on the mac computer . I can see it on the PC but on the media player I can't.
It have to be something simple. ... I am just not that smart.
 

DrKK

FreeNAS Generalissimo
Joined
Oct 15, 2013
Messages
3,630
So, just looking at SMB-related differences between 11.1U4 and 11.1U6, it would seem:

98% chance the problem is related to this (which I found here):

Known Impacts

SMB1 has been disabled by default for security reasons. If legacy clients are no longer able to connect, type this command in the Shell, then restart the SMB service:

sysctl freenas.services.smb.config.server_min_protocol=NT1

If that resolves the issue, you can make that setting permanent by going to System → Tunables →Add Tunable and creating a Tunable with these settings:


Variable: freenas.services.smb.config.server_min_protocol


Value: NT1
 
Last edited:

tiberiu

Neophyte
Joined
Dec 24, 2016
Messages
7
Thank you for your answer to my question.
I will do a clean install and try it again and I will post my results.
 

tiberiu

Neophyte
Joined
Dec 24, 2016
Messages
7
So, just looking at SMB-related differences between 11.1U4 and 11.4U6, it would seem:

98% chance the problem is related to this (which I found here):

Known Impacts

SMB1 has been disabled by default for security reasons. If legacy clients are no longer able to connect, type this command in the Shell, then restart the SMB service:

sysctl freenas.services.smb.config.server_min_protocol=NT1

If that resolves the issue, you can make that setting permanent by going to System → Tunables →Add Tunable and creating a Tunable with these settings:


Variable: freenas.services.smb.config.server_min_protocol


Value: NT1

YES !!! It worked !!! I love you man ! You are the best !!! Best Christmas present ! Thank you so much
 

DrKK

FreeNAS Generalissimo
Joined
Oct 15, 2013
Messages
3,630

sretalla

Wizened Sage
Joined
Jan 1, 2016
Messages
3,946
In 11.2 they put controls for it in the GUI, so no need for the tunable.
 

GrantWilson

Neophyte
Joined
Aug 7, 2019
Messages
6
Hello,

I had the same issue, when I upgraded to 11.2 and I didn't use any form of AD, however, I had to temporarily disable software firewalls as well, as the the share paths could not be found.
 

GrantWilson

Neophyte
Joined
Aug 7, 2019
Messages
6
So, just looking at SMB-related differences between 11.1U4 and 11.1U6, it would seem:

98% chance the problem is related to this (which I found here):

Known Impacts

SMB1 has been disabled by default for security reasons. If legacy clients are no longer able to connect, type this command in the Shell, then restart the SMB service:

sysctl freenas.services.essaydune.smb.config.server_min_protocol=NT1

If that resolves the issue, you can make that setting permanent by going to System → Tunables →Add Tunable and creating a Tunable with these settings:


Variable: freenas.services.smb.config.server_min_protocol


Value: NT1
Hello,

I had the same issue, when I upgraded to 11.2 and I didn't use any form of AD, however, I had to temporarily disable software firewalls as well, as the the share paths could not be found.
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
7,221
Hello,

I had the same issue, when I upgraded to 11.2 and I didn't use any form of AD, however, I had to temporarily disable software firewalls as well, as the the share paths could not be found.
The sysctl tunable has been deprecated in favor of a simple UI checkbox (enable SMB1 support). Try that. Also try connecting to your share by IP address \\<ip of server>\share.
 
Top