MPT0 errors on the console, how do you trouble shoot the problem?

Not open for further replies.


Aug 9, 2011
I've got a fairly new FreeNas setup. I had 8.0 installed but upgraded to 8.0.1 Beta 4 due to some other issues. Now I'm receiving the following errors on the console:

mpt0: request 0xffffff8000237160:47494 timed out for ccb 0xffffff0042604800 (req->ccb 0xffffff0042604800)
mpt0: request 0xffffff800022d110:47497 timed out for ccb 0xffffff0042606800 (req->ccb 0xffffff0042606800)
mpt0: request 0xffffff80002330b0:47503 timed out for ccb 0xffffff000bd92800 (req->ccb 0xffffff000bd92800)
mpt0: request 0xffffff800022ba00:47511 timed out for ccb 0xffffff0001ef1800 (req->ccb 0xffffff0001ef1800)
mpt0: request 0xffffff8000235540:47512 timed out for ccb 0xffffff0042608000 (req->ccb 0xffffff0042608000)
mpt0: attempting to abort req 0xffffff8000237160:47494 function 0
mpt0: completing timedout/aborted req 0xffffff8000237160:47494
mpt0: abort of req 0xffffff8000237160:0 completed
mpt0: attempting to abort req 0xffffff800022d110:47497 function 0
mpt0: completing timedout/aborted req 0xffffff800022d110:47497
mpt0: abort of req 0xffffff800022d110:0 completed
mpt0: attempting to abort req 0xffffff80002330b0:47503 function 0
mpt0: completing timedout/aborted req 0xffffff80002330b0:47503
mpt0: abort of req 0xffffff80002330b0:0 completed
mpt0: attempting to abort req 0xffffff800022ba00:47511 function 0
mpt0: mpt_wait_req(1) timed out
mpt0: mpt_recover_commands: abort timed-out. Resetting controller

I am currently running this off VMware ESXi 4.1. I have 5 2TB HD's connected to the onboard SATA controller. The HD's are hard mapped (I believe is what it's called) to the Virtual Machine so they are seen as local disks and don't rely on VMWare at all.

There is no telling when this will happen. I had the server running for months before issues started to plague me. I tried updating VMWare ESXi from 4.0 to 4.1 thinking that might have caused it.

Same problems. I updated FreeNas from 8.0 to 8.0.1 Beta 4, but still the problem persists.

The randomness shows when it works for 24+ hours with no issues, streaming videos, copying/pasting to and from, Bit torrents, ETC....

Then it locks. I have to restart the entire VMWare server (not just the FreeNas) to get it to restart and then it lasted for 6 hours or so, same thing, happened.

While typing this out I rebooted the VMWare server again because FreeNas stopped with the same error and while booting FreeNas, this error occurred while it was trying to mount the file system.

I'm trying to find out how I can pinpoint the problem. I can't find much about MPT0: errors off google, particularly the mpt_recovery_commands: abort timed out. I'm looking for how to fix this or a way to pin point where the problem might be so I have an idea on what might need to be replaced.

The VMWare server itself has a quad core processor with 8GB of ram. I'm giving FreeNas 1 processor and 4GB's of ram to work with. Let me know if I need to provide anything else.


May 8, 2012
I know it's an old post but I ha the same issue today on a fresh install.
i don't have any clu to resolve this problem.

i just know he appears during a transfert (CIFS or ftp) and whatever the size file.

I'm just exausted

If you have any solution i take them
Not open for further replies.