How to configure CIFS user access with authentication frow windows ?

Status
Not open for further replies.

astronaute

Dabbler
Joined
Jun 10, 2011
Messages
13
Hello all,

I would like to allow access to a shared folder only to authenticated users in a authorized group mediausers.
I cannot find solution to my problem anywhere on the Internet, so I post the question here as I'm sure it should be pretty simple to do what I need.

What I've already done:

1) Created group mediausers and added new user with name astronaute and password to it:
freenas1.png


2) Created RAIDZ volume /mnt/media:
freenas2.png


3) Changed volume permissions so only the group mediausers can read and write to it:
freenas3.png


4) Enabled CIFS without guest access and also with AIO enabled:
freenas4.png


[Post continues below as there is limit of 4 images per post]
 

astronaute

Dabbler
Joined
Jun 10, 2011
Messages
13
...

5) Created Windows share:
freenas5.png


6) Rebooted FreeNAS server just in case, tried to access it from my Windows 7 computer and get the "Access is denied" message:
freenas6.png


I've obviously done something wrong. Can someone please guide me on this ?

Thank you in advance !
 

Tekkie

Patron
Joined
May 31, 2011
Messages
352
Try rebooting your FreeNAS8, and do a search on the forum. ;)
 

astronaute

Dabbler
Joined
Jun 10, 2011
Messages
13
Try rebooting your FreeNAS8, and do a search on the forum. ;)
Already rebooted lot of times and tried different settings, also cannot find any solution that works in related posts, if you see some obvious misconfiguration that I miss, please tell me.
 
B

Bohs Hansen

Guest
try to change the users home directory to /mnt/media/ .. might help, might not
 

Tekkie

Patron
Joined
May 31, 2011
Messages
352
You should set inherit permissions on the share AFAIK, and there is at least one thread on the forum which discuss how to setup CIFS, sorry can't find it right now.
 

astronaute

Dabbler
Joined
Jun 10, 2011
Messages
13
Well, I changed users home to /mnt/media/ and tried changing other settings and rebooted few times in between, and now it seems to be okay.

Thank you guys for trying to help me :)
 

fishermsu

Cadet
Joined
Jun 21, 2011
Messages
1
Astronaute..

I installed my first FreeNAS today and I have the same issue as you. I search a while and find one article that said change the CIFS settings permissions from Local User to Anonymous. The article said it was in the documented in a manual as how CIFS should be setup, but I hadn't found any documentation like that. After I made the change I was able to login to the share, but upon trying to write data I then got an access denied. After looking I went to the Dataset permissions and enabled "Other" write access. It was like it used user authentication for the share, but when inside the share and writing data it decided to use anonymous access. So i went and grabbed a Linux guru down the hall and he wanted to look at the smb.conf directly and compared the GUI to a hand written smb.conf and he felt it was a little messy. So he was saying something about the share maybe using UNIX permissions, but once in the share using SMB permissions or something to that nature. We tried editing directly but called it a day before we finished. I don't know yet if this is the issue, but this is what we are pursuing. Oh also since my Win 7 computer is connected to a domain I had to make sure that my login (when connecting to the share) was "workgroupname of freenas\username" (case sensitive). I'm glad a many reboots fixed your issue, but something doesn't seem right with it. Every time I made a change I made sure I restarted the CIFS service but it didn't seem to fix it. I will re post if we find anything.

Thanks
FM
 

jenksdrummer

Patron
Joined
Jun 7, 2011
Messages
250
Create a ZFS Pool called Media. Use a generic name for the actual ZFS array.

For example you should have mnt/zfs_raidz
Under that, create a ZFS Pool /mnt/zfs_raidz/media

Assign your permissions to the ZFS Pool 'Media' - for some reason it seems that writing to the root of the ZFS Array is restricted unless you set "others" to enable read/write/execute, and turn on anonymous access at the share and CIFS level. Also make sure your share is pointed at the ZFS Pool, and that you have everything else configured correctly.

With this method, it works at the owner/group level, and isn't looking at "others" for permissions with local user access configured.

You may also need to bounce the CIFS service to make these changes take effect.
 

nasandy

Cadet
Joined
Jul 1, 2011
Messages
4
On my FreeNas setup I have to use the following:

username: nameofnasbox\useraccount

password: mypassword

So, you should use:

username: nameofnasbox\astronaute

password: yourpassword

The screenshot shown is trying to use the local PC account as the domain.

Hope that helps.

Andy
 

facethewolf

Dabbler
Joined
Dec 13, 2011
Messages
21
nasandy
YOU ARE A GENIUS!!! THank You THank You THank You THank You THank You THank You THank You THank You THank You THank You THank You
 
Status
Not open for further replies.
Top